Instalace nejnovějších ovladačů grafik Intel v Linux Mintu

int1Jelikož je i mezi našimi čtenáři celá řada majitelů grafických karet Intel, tak si myslím, že bychom na ně měli také pamatovat a i jim umožnit instalaci nejnovějších ovladačů těchto grafických karet v Linux Mintu.

Intel Graphics Installer for Linux je svobodný nástroj, který lze použít k instalaci nejnovějších ovladačů grafických karet Intel. Je vyvíjen a udržován komunitou Intel Open Source Technology Center. Jeho instalace vám umožní mít stále k dispozici ta nejnovější vylepšení, optimalizace a opravy hardwaru Intel Graphics. Nástroj Intel Graphics Installer for Linux je v současné době k dispozici i pro Linux Mint.

 

Instalace v Linux Mint 17.1 (17)

Aby byl balíček Intel Graphics Installer For Linux pro váš systém důvěryhodný, budete si nejprve muset přidat klíč do Správce softwaru. Ten si přidáte zadáním příkazů v terminálu:

Příkazy terminálu:
wget –no-check-certificate https://download.01.org/gfx/RPM-GPG-KEY-ilg -O – | sudo apt-key add –
wget –no-check-certificate https://download.01.org/gfx/RPM-GPG-KEY-ilg-2 -O – | sudo apt-key add –

 

Po té přejděte se na oficiální download stránku a stáhněte si nejnovější balíček podle vaší vaší architektury. V současnosti je poslední verze balíčku Intel Graphics Installer for Linux 1.0.7. Přímý odkaz je zde:

 

Poté nainstalujte stažený .deb soubor pomocí příkazů:

Příkazy terminálu:
sudo dpkg -i intel-linux-graphics-installer_1.0.7-0intel1_*.deb
sudo apt-get install -f

 

Použití

Jakmile jste si program nainstalovali, spusťte jej z Menu nebo z terminálu pomocí následujícího příkazu:

Příkazy terminálu:
intel-linux-graphics-installer

 

Klepněte na tlačítko Begin pro nalezení aktualizací….

 

int2

 

Intel Graphics Installer for Linux stáhne seznam dostupných aktualizací ovladačů videa. Klepnutím na tlačítko Install spusťte aktualizaci ovladačů Intel.

 

int3

 

Teď se bude aktualizovat váš systém na nejnovější ovladače Intel Graphics.

 

int4

 

Klepněte na tlačítko Close pro dokončení procesu upgradu. Můžete si zobrazit seznam aktualizovaných balíků po kliknutí na tlačítko Report.

 

int5

 

Konečně, restartujte počítač, aby se změny projevily.

Jelikož já grafiku Intel nevlastním, rád uvítám v komentářích vaše poznatky jednak z instalace a následně i používání tohoto ovladače.

Přeji bezproblémové používání popsaného programu.

 

 

Štítky , , , , , .Záložka pro permanentní odkaz.

39 reakcí na Instalace nejnovějších ovladačů grafik Intel v Linux Mintu

  1. René Frick říká:

    Mint 17.1 cinnamon, 64-bit – vypise, ze tato distribucia nie je podporovana.

    wget –no-check-certificate https://download.01.org/gfx/RPM-GPG-KEY-ilg -O – | sudo apt-key add –

    vypisal, ze nenasiel openpgp kluce

  2. Vikina říká:

    Tento nástroj som pred niektoľkými mesiacmi skúšala a vždy pri kroku CHECKING DISTRIBUTION vypíše chybu a nie je možné pokračovať. (Linux mint 17, 32 bit. Intel integrovaná)

  3. Kagkouro říká:

    Už se to někde řešilo,bohužel teď nemám čas hledat,ale je třeba někde přepsat Mint na Ubuntu,pak to funguje:)))

  4. Morko říká:

    stačí editnout text v /etc/lsb-release a přepsat na:
    DISTRIB_ID=ubuntu
    DISTRIB_RELEASE=14.04
    DISTRIB_CODENAME=trusty
    popř. upravit podle Vaší konfigurace

    • kamowski říká:

      akosi sa mi to nedarí 🙁
      editovaním súboru som dosiahol akurát, že sa nedostanem do
      menu > správa > zdroje softvéru
      —-
      ak ste si to tiež pooné bez zálohovania pôvodného, prepíšte si to späť:
      DISTRIB_ID=LinuxMint
      DISTRIB_RELEASE=17.1
      DISTRIB_CODENAME=rebecca
      DISTRIB_DESCRIPTION=“Linux Mint 17.1 Rebecca“

  5. mac mac říká:

    Už jsem to řešil několikrát a neustále stejný výsledek jako kamowski

  6. Kagkouro říká:

    Tenhle prográmek prostě v Mintu nefunguje,sám sem zkoušel za uplynulé roky mnohokrát,vývojáři stále neví že existuje Mint.A přepisovat nic nebudu.Stačiklo by kdyby si autor toto zjistil,páč toto fakt není návod pro Linux Mint:)))))

    • Satapouch říká:

      Právě proto jsem to psal, aby se rozbouřila diskuze, zkus si článek přečíst znovu, hlavně konec.
      A zrovna od Tebe, bych házení klacků pod nohy nečekal…..

      • Kagkouro říká:

        Ale no tak,.žádný klacky,já jen že ten program znám,a bez úprav nefunguje.prostě nezná LM,zná jen Ubuntu.Takže jen narážka,přidat do článku tu úpravu pro LM:)

    • Allconius říká:

      Co je pro Ubuntu je i pro Mint 🙂

  7. mibo říká:

    *** Přepisovat nepřepisovat doplnění: ***
    před spuštěním „intel-linux-graphics-installer“
    1. zmáčkněte ALT + F2 a tam: gksudo gedit
    2. zadejte vaše heslo
    3. Ve spuštěném GEDITU nahraďte VŠE již zmíněným
    DISTRIB_ID=Ubuntu
    DISTRIB_RELEASE=14.04
    DISTRIB_CODENAME=trusty
    DISTRIB_DESCRIPTION=“Ubuntu 14.04 LTS“
    4. Dejte uložit (CTRL+S), ale nezavírejte
    5. Naistalujte dle návodu intel-linux-graphics-installer
    6. Vraťte se doufám že do nezavřeného GEDITU a dejte tolikrát zpět (CTRL+Z) kolik je potřeba k původnímu obsahu a opět uložte (CTRL+S).
    7. Samotný balík instalátoru klidně odeberte přes vaše oblíbené tool na správu balíku, protože již není potřebný. Tool nainstalil správné balíky a přidá intel repozitáře a tudíž by se dále již měl systém updatovat bez potřeby cokoliv měnit.

    • mibo říká:

      ups v bodu jedna sem to nenapsal celé :D, tož oprava
      1. zmáčkněte ALT + F2 a tam: gksudo gedit /etc/lsb-release

  8. René Frick říká:

    2014-12-07 13:09:16 (757 MB/s) – „–“ uložené [1753/1753]

    hned po zadani 1. prikazu (wget –no-check-certificate https://download.01.org/gfx/RPM-GPG-KEY-ilg -O – | sudo apt-key add -) mi po chvilu cakania vypise:

    UKONČENÉ –2014-12-07 13:09:16–
    Celkový čas: 0,2s
    Stiahnutých: 1 súborov, 1,7K za 0s (757 MB/s)

    Sorry, try again.
    [sudo] password for XXXXX:
    gpg: nenájdené žiadne platné dáta vo formáte OpenPGP.

    • mibo říká:

      A zadal si heslo k tomu sudo? Možno lépe proveď to rovnou pod rootem, neboli před použitím dej příkaz „sudo -i“ a dej svoje heslo.

      • Vikina říká:

        Ďakujem 🙂 Super postup a funkčný 🙂 Úple bez zaváhania. Funguje super 🙂

  9. Sam říká:

    Mám tento program od samého začátku na Lubuntu – nalezl jsem ho cca 3 měsíce zpět na OMGubuntu/ubuntuportal, nevím už.. Nainstaloval mi potřebné součásti, grafika jede skvěle. Teď nedávno vyšla aktualizace, tak jsem systém projel znova nainstalovalo mi to nějaký nový součásti. Jede pořád parádně. Jen si pamatuju, že mi to poprvý nějak rozhodilo apt, tak jsem to něčím fixoval. Jinak super 🙂

    • Tom říká:

      Povedlo se to nekomu rozjet v Mintu 17 ?

      • Allconius říká:

        Ahoj, jasně, to funguje od té doby co to jede na Ubuntu 🙂 Měl jsem to instalované už na LM13, jen je třeba zeditovat ten soubor lsb-release nainstalovat a pak zas vrátit zpět původní, to je celý 🙂

    • Tak jsem zkoušela na Lubuntu, což si myslím že by nebyl problém ve spojitosti s Ubuntu, nicméně mi to hlasí 404 nenalezen balíček.

  10. Vergas říká:

    Instalace se povedla podle návodu od „mibo“. Díky mibo! 🙂

  11. George říká:

    Tak už jsem to několikrát zkoušel, bohužel asi mám blbou desku. Na konci všeho je You don’t seem to have an Intel i915 chipset so no updates are needed 🙁 Měl by někdo nějaký nápad? Díky

  12. Pačula říká:

    Tak hlásím že na Mintu 17 jsem již tento program rozchodila.. opravdu stačilo upravit v Geditu z Mintu na Ubuntu a vše proběhlo v pořádku :-)https://plus.google.com/101784338798333138073/posts/7W8YX8bCVep

  13. George říká:

    Zdravím, tak ještě jsem chtěl upřesnit typ desky, je to ASRock AD2550B-ITX, tak kdyby někdo měl nějakou zkušenost s tímto peklem….

  14. René Frick říká:

    robili ste to od zaciatku aj s tym wget… ? mne vzdy ten 1. neprejde. stale zostane ako keby zaseknuty. zistil som ze caka admin pass, ale vzdy skonci z chybou ze nebol najdeny ziaden platnu OpenPGP.
    ked dam instalovat:

    Checking if Intel graphics card available… OK
    Retrieving information from 01.org… OK
    Checking distribution… Failed

    samozrejme, zeditoval som /etc/lsb-release

  15. René Frick říká:

    takze… chybicky su tu 😉

    tie wget maju vyzerat takto:
    wget –no-check-certificate https://download.01.org/gfx/RPM-GPG-KEY-ilg -O – | sudo apt-key add –

    wget –no-check-certificate https://download.01.org/gfx/RPM-GPG-KEY-ilg-2 -O – | sudo apt-key add –

    nie nejake divne pomlcky a 0 (nula) miesto O (velke O)

    dalej potom ten installer treba spustat ako sudo 😉

  16. Peter říká:

    Asi blba otazka. Ako zistim, ze sa mi tie Intelovske ovladace nainstalovali spravne? Vsetko prebehlo ok, ale zmenu nevidim. V hre Left 4 Dead 2 mi grafika blbla aj predtym aj teraz po instalacii tychto ovladacov. Blbne tak, ze hra je ciernobiela a prakticky vsetko v hre je ako keby zlozene z kociek, tienov a takych divnych tvarov. Proste nehratelne. Hra je original na linux. Myslel som si, ze s tymito ovladacmi to bude OK.

  17. Furghrim říká:

    zdravím…. mě to vyhodí tuhle chybu při instalování balíčků

    W:Failed to fetch https://download.01.org/gfx/ubuntu/14.04/main/dists/trusty/main/binary-amd64/Packages server certificate verification failed. CAfile: /etc/ssl/certs/ca-certificates.crt CRLfile: none
    , W:Failed to fetch https://download.01.org/gfx/ubuntu/14.04/main/dists/trusty/main/binary-i386/Packages server certificate verification failed. CAfile: /etc/ssl/certs/ca-certificates.crt CRLfile: none
    , E:Some index files failed to download. They have been ignored, or old ones used instead.

  18. Barthezz říká:

    btw pro 17.1 :
    DISTRIB_ID=Ubuntu
    DISTRIB_RELEASE=14.10
    DISTRIB_CODENAME=utopic
    DISTRIB_DESCRIPTION=“Ubuntu Utopic Unicorn (development branch)“

  19. theseuszn říká:

    Zdravím, byť je tady poslední aktivita z dubna, ale neva, snad sem někdo nahlédne 🙂 Mám prosím jednoduchý dotaz směrem k těm, co používají nějaký ten „strojek“ s inteláckým GPU, zda jim ta úprava, kterou si zavedli a držela jim, jestli jim drží i po povýšení Mintu ze 17.1 na 17.2. Na nově zavedeném LM 17.2, x64Cinnamon mám bohužel zatím smolíka jak v původním kernelu, tak i v novějších a to na notesu Acer Aspire E15 Start…
    PS. Samozřejmě případné kladné info budu brát nezávazně, elektronika je tak nějak potvora 🙂 Předem děkuji za případnou reakci a za váš drahocenný čas…

  20. feri říká:

    Ahoj. Mám ve stolním PC CPU Intel Pentium G3420 Haswell 2x 3,2Ghz s integrovanou grafikou. Po povýšení ze 17.1 na 17.2 žádný problém. Všechno proběhlo v naprostém pořádku.

  21. jiho říká:

    Ahoj, Mint 17.2 32 bit, Cinnamon grafická karta Intel Corp. Mobile GM965/GL960 Integrated Graphics Controller, po instalaci zmizely ikony na ploše, některé ikony v systémové liště se rozpadly, některé se vůbec nezobrazují. Po přepnutí do SW renderování vše OK. Jak se dají tyto ovladače odinstalovat? Díky předem a omlouvám se za možná hloupý dotaz.

  22. teekey říká:

    Pro Linux Mint 18.1:
    /etc/lsb

    DISTRIB_ID=Ubuntu
    DISTRIB_RELEASE=16.04
    DISTRIB_CODENAME=xenial
    DISTRIB_DESCRIPTION=“Ubuntu Xenial Xerus (development branch)“

    seznam podporovanych distribuci potom zde:
    https://download.01.org/gfx/ubuntu/16.10/main/dists/

  23. R.A. říká:

    Dobry den uspesne jsem nainstaloval grafiku podle navodu na techto strankach https://unix.stackexchange.com/questions/315049/cannot-install-intel-graphics-driver-on-linux-mint-18 .
    Postup je zde cely i s prepsanim verze sistemu aby si instalator myslel ze je to sistem ubuntu 16.04.

  24. Tomáš říká:

    Zdravím,
    mám jeden problém. Stáhl jsem si poslední verzi instalátoru pro můj systém (Linux Mint 18.2 x64 – verze pro Ubuntu 16.04 x64). Vše běží OK a po stažení nějakých souborů z internetu zahlásí instalátor chybu. Zobrazí se tato dvě okna:

    1) Error running transaction: GDBus.Error:org.debian.apt. TransactionFailed: error-dep-resolution-failed: The following packages have unmet dependencies:

    libgles1-mesa: Depends: libglapi-mesa (=12.0.6-0ubuntu0.16.04.1) but 17.0.7-0ubuntu0.16.04.1 is to be installed

    2)The following packages have unmet dependencies:

    libgles1-mesa: Depends: libglapi-mesa (=12.0.6-0ubuntu0.16.04.1) but 17.0.7-0ubuntu0.16.04.1 is to be installed

    Instalátor zahlásí „Failed“ a nedá se v instalaci pokračovat …

    Můžete mi s tímto problémem pomoci?

    Mám Intel 82945G/GZ Integrated Graphics Controller, IC2D E4500, 2GB RAM, intel-graphics-update-tool_2.0.2_amd64.deb., FHD monitor Asus.

    Díky moc.

  25. Tomáš říká:

    Nikdo nic?

  26. takyradějianonymně říká:

    tyhle už dost technický věci natož s ovladači grafiky bych řešil dotazem na fóru a ne u už staršího článku