LibreOffice 7.0 vydáno, nabízí akceleraci Vulkan

The Document Foundation oznámila vydání nové hlavní verze kancelářského balíku LibreOffice 7.0. Mezi novinkami najdeme přechod od vykreslovací knihovny Cairo na akcelerovanou Skia, za jejímž vývojem stojí Google. Dále je k dispozici i GPU akcelerace skrze API Vulkan.

Sedmička také přináší podporu dokumentového formátu ODF 1.3, vylepšenou kompatibilitu s formáty Microsoft Office (docx, xlsx, pptx), vylepšení uživatelského rozhraní, podpory HiDPI, importu i exportu různých formátů …

… Více v článečku od David Ježek na stránce ZDE.

https://cs.libreoffice.org/download

Před instalací je nutno odstranit původní instalaci Libre nebo Open Office:

sudo apt-get remove libreoffice-core

Odinstalace všech balíků LO:

sudo apt purge $(dpkg -l | grep libreoffice | awk ‚{print $2}‘)

Instalace pomocí zdroje, vyzkoušena uživatelem Petr F. ve VM:

Přidání repozitáře LO. V budoucnu se v něm budou objevovat verze 7.0.1, 7.0.2, 7.0.3 atd. Aktuální verze je 7.0.0.3:

sudo add-apt-repository ppa:libreoffice/libreoffice-7-0
apt update && apt upgrade -y && apt full-upgrade -y

Instalace LO 7.0.0.3:

apt install -y libreoffice

Instalace češtiny:

apt install -y libreoffice-l10n-cs

Instalace české nápovědy:

apt install -y libreoffice-help-cs

Nebo můžete instalovat ze zdrojového kódu:

Krok 1: Získání instalačního zdroje a použití Terminálu:

wget https://ftp.gwdg.de/pub/tdf/libreoffice/stable/7.0.0/deb/x86_64/LibreOffice_7.0.0.3_Linux_x86-64_deb.tar.gz

Krok 2: Stažení archivu a jeho rozbalení:

tar -xf LibreOffice_7.0.0.3_Linux_x86-64_deb.tar.gz

Krok 3: Přihlášení jako Root nebo instalace pomocí SUDO:

cd DEBS && sudo dpkg -i *.deb

Článek byl napsán (ne vydán) v době, kdy ještě nebyly dostupné zdroje pro instalaci ani články ze zahraničních stránek. Díky Vaší pomoci bylo vše doplněno.

Děkuji.

Přidání repozitáře fresh, který v budoucnu bude automaticky aktualizovat LO z 7.0.x na 7.1.x (zatím nedostupný):

sudo add-apt-repository ppa:libreoffice/ppa
apt update && apt upgrade -y && apt full-upgrade -y

Až se v budoucnu fresh repozitář začne používat, tak ten předchozí se používat přestane, protože systém zaznamená dostupné novější verze.

Pro jistotu nechávám na tomto místě i původní příkazy uvedené v článku:

Repozitář si můžete přidat takto:

sudo add-apt-repository ppa:libreoffice/libreoffice-7-0

sudo apt update

sudo apt install libreoffice

Poznámka:

Nemám odzkoušeno, instalujete na vlastní nebezpečí … Bohužel to nemusí fungovat …

Záložka pro permanentní odkaz.

27 reakcí na LibreOffice 7.0 vydáno, nabízí akceleraci Vulkan

  1. Petr Fiedler říká:

    Zdravím,
    přidal jsem si ten repositář, ale na sedmičku se mi LO nepovýšily. Mám teď verzi 6.4.5.2.

  2. Anonym říká:

    Najnovšia verzia – Fresh Full version – na stiahnutie odtiaľto:
    https://www.libreoffice.org/download/appimage/

  3. jarek163 říká:

    V tomto repositáři LibreOffice 7.0 ještě není. Zkus tento repositář
    sudo add-apt-repository ppa:libreoffice/libreoffice-prereleases
    Nebo nainstalovat ručně ze stránek libreoffice

    • labeent říká:

      Děkuji, doplněno do původního článku.

      • Petr Fiedler říká:

        sudo apt-get remove libreoffice-core
        sudo add-apt-repository ppa:libreoffice/libreoffice-7-0
        Nedaří se přidat PPA repozitář: „’Toto PPA nepodporuje focal’“.

      • Petr Fiedler říká:

        Nechápu, proč píšeš o něčem, čemu nerozumíš/nemáš vyzkoušeno. Postupoval jsem podle tvých rad a rozbil si systém. Teď nemůžu nainstalovat LO vůbec.

        ~$ apt install libreoffice
        Načítají se seznamy balíků… Hotovo
        Vytváří se strom závislostí
        Načítají se stavové informace… Hotovo
        Některé balíky nemohly být instalovány. To může znamenat, že požadujete
        nemožnou situaci, nebo, pokud používáte nestabilní distribuci, že
        vyžadované balíky ještě nebyly vytvořeny nebo přesunuty z Příchozí fronty.
        Následující informace vám mohou pomoci vyřešit tuto situaci:

        Následující balíky mají nesplněné závislosti:
        libreoffice : Závisí na: libreoffice-base ale nebude se instalovat
        Závisí na: libreoffice-report-builder-bin ale nebude se instalovat
        Doporučuje: libreoffice-report-builder ale nebude se instalovat
        E: Nelze opravit problémy, některé balíky držíte v porouchaném stavu.

        • labeent říká:

          Rady jsou z externího článku. A autor nemůže vždy vše vyzkoušet. Je mi líto, že Vám to nefunguje, ale za to nemohu.

          • Petr Fiedler říká:

            Píšeš o LO7. Dáš sem ppa, které s LO7 nemá nic společného. Nevěděl jsi to, protože si to před tím nevyzkoušel a nemůžeš za to? A kdo za to tedy může? Já? Systém jsem si už obnovil a vše mi funguje. Pokud ale píšeš a nevíš o čem, tak tvé články nemá smysl číst.

            • labeent říká:

              Ano, máš pravdu. V době, kdy jsem článek psal ještě nebyl žádný repozitář k dispozici, nebyl ani článek. Po včerejším upozornění od jiného uživatele jsem přepsal repozitář a všechny příkazy dle tohoto článku.
              Že jsem neměl čas to vyzkoušet je věc druhá.
              A jelikož si myslíš to, co si myslíš, tak Ti oznamuji, že rozumím Tvému naštvání, jsem rád, že se Ti podařilo obnovit systém a už se nemusíš bát. Byl to ode mne předposlední článek. V pondělí vyjde poslední (je už pár dní napsaný a naplánovaný) a pak už nic. Tímto končím s vydáváním článků na tomto webu. A ještě jednou se Ti omlouvám za to, že Tě můj článek uvedl v omyl …

              • Petr Fiedler říká:

                Já nejsem naštvaný. Spíše jsem chtěl, aby ses nad tím zamyslel. Nezlobím se na tebe. Vše mi funguje. Proč končíš?

              • labeent říká:

                Už jsem z toho moc unavený. Nikdo se nesnaží něco vydat. Tak jsem se snažil já + jsem navrhl a implementoval vydávání odkazových článků na zajímavé věci kolem Linuxu, grafiky apod. Posledních 14 dní jsem měl v zaměstnání napilno (je to pravidelně – tedy sezóna) a přesto jsem si utrhl z volného času a vydal pár článků. Bohužel už nebylo v mé moci si vše v nich vyzkoušet. Jinak bych na ty problémy také přišel. Vesměs vše, o čem jsem tady psal, jsem vždy zkoušel. Jen vyjímečně ne.
                Teď jsem se k tomu z časových důvodů nedostal a hned se mi to vymstilo, respektive Tobě, a to mi mrzí.
                Zítra mi konečně začne dovolená a hodlám si odpočinout. Je už na čase, aby se více zapojila komunita, já už toho tady udělal dost. Ne vše bylo povedené, ale někdy bylo dost ohlasů, že to lidem pomohlo. Tak snad jsem tady s těmi laickými články byl užitečný. Doufám, že mě brzy někdo nahradí.

          • redhawk75 říká:

            to je fajn,ze si prebral clanok ale treba to odskusat ked nieco pises. vyhnes sa zbytocnemu osocovaniu.
            —-
            Tímto končím s vydáváním článků na tomto webu.
            Tak to je skoda, ale nedivim sa.
            tiez som tym presiel 😉

    • Petr Fiedler říká:

      PPA z tohoto odkazu taky nefunguje, viz.: https://www.abclinuxu.cz/poradna/linux/show/442965#22

  4. Old Bobby říká:

    Pánové, přece nebudeme mít o prázdninách rudou mlhu před očima a krevní tlak 190/100 ?
    Občas se něco nepovede, tak proč si ubližovat ?
    Přeji labeent-ovi pěknou dovolenou, odpočinutí od „práce, která šlechtí“ a všem ostatním, kteří to ještě nestihli, totéž.
    Je pravdou, že mezi uživateli Mintu je určitě dost lidí, kteří umí víc, než naťukat SMS; napsat článek není zase taková hrůza – sám jsem jich publikoval ~250 během pěti let. Jenže už jedu deváté gumy, inspirace, výkon a libido se pomalu, ale jistě ztrácí: Na psaní článků už prostě nemám.
    Chápu obavy těch, kteří by i psali, ale autocenzura a strach jim svazují ruce.
    Na urážky a dehonestaci si dnes bohužel musíme zvykat.
    Stále je ale jednodušší kritizovat, než něco vytvořit.
    Tak si to proberte a pište, dokud ještě máme svobodu slova; čas a běženci běží, tak na co čekáte?

  5. Pepan říká:

    Taky bych chtěl labeentovi velice poděkovat za články. Možná si to ještě rozmyslíš. Na druhou stranu se ti nedivím, navíc některá třeba i oprávněná kritika se dá napsat neurážlivým způsobem. Mnoho uživatelů si myslí že se snad autor psaním živí. Labeente psal jsi hezky čtivé články to každý neumí.

  6. Petr Fiedler říká:

    Tady je postup, který jsem vyzkoušel ve VM a funguje:

    # Odinstalace všech balíků LO:
    sudo apt purge $(dpkg -l | grep libreoffice | awk ‚{print $2}‘)

    # Přidání repozitáře LO. V budoucnu se v něm budou
    # objevovat verze 7.0.1, 7.0.2, 7.0.3 atd. Aktuální verze je
    # 7.0.0.3
    sudo add-apt-repository ppa:libreoffice/libreoffice-7-0
    apt update && apt upgrade -y && apt full-upgrade -y

    # Instalace LO 7.0.0.3:
    apt install -y libreoffice

    # Přidání repozitáře fresh, který v budoucnu bude automaticky
    # aktualizovat LO z 7.0.x na 7.1.x (zatím nedostupný):
    sudo add-apt-repository ppa:libreoffice/ppa
    apt update && apt upgrade -y && apt full-upgrade -y
    # Až se v budoucnu fresh repozitář začne používat, tak ten
    # předchozí se používat přestane, protože systém zaznamená
    # dostupné novější verze.

    # Instalace češtiny:
    apt install -y libreoffice-l10n-cs

    # Instalace české nápovědy:
    apt install -y libreoffice-help-cs

    • labeent říká:

      Děkuji, doplněno do článku. Kdybys přišel na nějaký problém, tak dej vědět.

      • Petr Fiedler říká:

        Není zač. Rád pomůžu.

        Není to vyloženě chyba, ale zjistil jsem, že v obou případech pri přidání PPA je zbytečné za apt update psát:

        && apt upgrade -y && apt full-upgrade -y

      • Petr Fiedler říká:

        A objevil jsem chybu. Když jsem sem vkládal příkaz pro „Odinstalace všech balíků LO:“, tak web ten příkaz změnil. Ten první apostrof před složenou závorkou má být nahoře. Při kopírování jej ale tento web přehodí dolů. Pamatuji si, že už zde s tím měl někdo v minulosti taky problém. Řešením je napsat ten apostrof jako html tag.

      • Petr Fiedler říká:

        Tak && apt upgrade -y nakonec možná bude dobré. Nedovedu to teď ale úplně posoudit. Právě si LO přeinstalovávám v primárním systému a po apt update mi to nějaké aktualizace nabídlo. Nějakou dobu jsem ale už neaktualizoval a nedokážu teď posoudit, jestli ty balíky s LO souvisí, nebo ne. Každopádně když se to nechá jak jsem psal prvně, tak to nemůže ničemu uškodit. Maximálně se nic neaktualizuje.

  7. uživatel říká:

    Jako zdroj lze použít i archivy:
    https://downloadarchive.documentfoundation.org/libreoffice/old/

    pro použití v Terminálu (nutné odinstalovat aktuální verzi) a to i na starší verze (lépe mi vyhovuje na mintu 20 verze LO 5.3.7.2, která má Quickstarter, verze 5.4.7.2 se seká při vypínání stroje)

  8. Jednoduchá instalace říká:

    Mě fungovalo normální přidání PPA repozitáře, pak jen „sudo apt-get update“ + „sudo apt-get dist-upgrade“ a nové LO jsou nainstalovány.
    Otestováno s Ubuntu 20.04.1 LTS

Napsat komentář

Vaše emailová adresa nebude zveřejněna.