Jak upgradovat LMDE 1 na Linux Mint Debian Edition 2.0 Betsy

1099__90x90_linux-mint-15_0V dnešním malém tutoriálu se pokusím poradit uživatelům LMDE 1 jak pokud možno „bezbolestně“ aktualizovat svůj systém na nedávno vydanou verzi LMDE 2 Betsy.

Linux Mint Debian Edition (LMDE) je semi-rolling linuxová distribuce založená na Debianu. Je k dispozici jak pro 32-bitové, tak i pro 64 bitové systémy s pracovními prostředími MATE a Cinnamon. LMDE není kompatibilní s Linux Mintem, založeným na Ubuntu. LMDE 2.0 je založen na Debian Jessie a dosud ještě nepřešel na správce služeb systemd.

 

lmde_mate

 

lmde_cinnamon

 

Pro úspěšnou aktualizaci se předpokládá, že:

  • Máte slušné zkušenosti s APT
  • Používáte podporované vydání (tj. buď s Cinnamonem nebo s MATE)
  • Váš systém LMDE 1 je aktualizován na Pack 8
  • Jste neupgradovali z Debian Testing nebo Debian Unstable.
  • Nepoužíváte repozitář Romeo (pokud ano, před upgradem jej vypněte).
  • Váš init systém je Sysvinit (tedy, že jste nepřešli na systemd).

 

Ještě než začnete:

  • Vytvořte si zálohu (např. obraz/snímek vašeho systému na HDD), takže si později můžete obnovit vše do původního stavu.
  • Nejprve si vyzkoušejte live verzi LMDE 2 Betsy a ujistěte se, že dobře spolupracuje s vaším hardwarem (Betsy má novější jádro, novější libs, novější ovladače..).

 

Pokyny pro upgrade:

Jako první si přidejte potřebné repozitáře do vašeho systému:

Příkazy terminálu:
sudo sh -c 'echo "deb http://packages.linuxmint.com betsy main upstream import" > /etc/apt/sources.list.d/official-package-repositories.list'
sudo sh -c 'echo "deb http://http.debian.net/debian jessie main contrib non-free" >> /etc/apt/sources.list.d/official-package-repositories.list'
sudo sh -c 'echo "deb http://http.debian.net/debian jessie-updates main contrib non-free" >> /etc/apt/sources.list.d/official-package-repositories.list'
sudo sh -c 'echo "deb http://security.debian.org jessie/updates main contrib non-free" >> /etc/apt/sources.list.d/official-package-repositories.list'
sudo sh -c 'echo "deb http://www.deb-multimedia.org jessie main non-free" >> /etc/apt/sources.list.d/official-package-repositories.list'
sudo sh -c 'echo "deb http://extra.linuxmint.com betsy main" >> /etc/apt/sources.list.d/official-package-repositories.list'

 

Dále aktualizujte mezipaměť APT:

Příkazy terminálu:
sudo apt update
sudo apt install debian-archive-keyring deb-multimedia-keyring
sudo apt update

 

Nainstalujte potřebné balíčky:

Příkaz terminálu:
sudo apt install sysvinit-core adwaita-icon-theme blueberry

 

Upgradujte, opravte porušené závislosti:

Příkazy terminálu:
sudo apt dist-upgrade
sudo install -f 

 

Instalujte buď Cinnamon:

Příkaz terminálu:
sudo apt install mint-meta-debian-cinnamon

 

nebo Mate:

Příkaz terminálu:
sudo apt install mint-meta-debian-mate

 

A na závěr restartujte:

Příkaz terminálu:
sudo reboot

 

Po restartu byste již měli nabootovat do nejnovější LMDE verze Linux Mintu.

Přeji hodně štěstí při upgradu!

Zdroj: http://community.linuxmint.com/tutorial/view/2013

 

Štítky , , , , , , .Záložka pro permanentní odkaz.

Komentáře jsou uzavřeny.