FF – Multi Converter

ffm1FF-Multi Converter je jednoduchá grafická aplikace, která umožňuje převést audio či video soubory, obrázky a dokumenty do všech populárních formátů, jež používají a kombinují různé jiné programy.

Aplikace využívá ffmpeg pro audio/video soubory, unoconv pro soubory dokumentů a knihovnu PythonMagick pro konverzi obrázkových souborů.
Cílem FF multi Converteru je shromáždit všechny multimediální typy v jediné aplikaci a poskytnout možnost jejich snadné konverze přes uživatelsky přívětivé rozhraní. Další možnosti konverze jsou postupně doplňovány. Aplikace je napsaná v jazyce python3 a PyQt4. Veškerý kód je šířen pod licencí GNU General Public License, verze 3.

 

Vlastnosti:

  • Konverze pro více formátů souborů
  • Velmi snadno použitelné rozhraní
  • Přístup k běžným možnostem konverze
  • Předvolby pro nastavení audio/video formátu ffmpeg
  • Možnosti pro ukládání a pojmenovávání souborů
  • Rekurzivní (zpětná) konverze

 

Podporované formáty:

  • Audio/Video formáty:
    • aac, ac3, AFC, AIFF, amr, asf, au, avi, dvd, flac, flv, MKA, mkv, MMF, mov, mp3, mp4, mpg, ogg, ogv, PSP, rm, SPX, vob, wav, WebM, wma, wmv a další formát, který podporuje ffmpeg.

 

  • Obrazové formáty:
    • bmp, CGM, DPX, EMF, EPS, FPX, GIF, JBIG, JNG, jpeg, MrSID, p7, pdf, Picon, png, ppm, PSD, rad, TGA, TIF, webp, XPM

 

  • Formáty souborů dokumentů:
    • doc > odt, pdf
    • html > odt
    • ODP > pdf, ppt
    • ods > pdf
    • odt > doc, html, pdf, rtf, sxw, txt, xml
    • ppt > odp
    • rtf > odt
    • SDW > odt
    • sxw > odt
    • txt > odt
    • xls > ods
    • xml > doc, odt, pdf

 

ffm2

 

ffm3

 

ffm4

 

Máte-li zájem nainstalovat si aplikaci FF-Multi Converter v Linux Mintu, otevřete terminál (např. Ctrl + Alt + T ) a zadejte postupně následující příkazy:

Příkazy terminálu:
sudo add-apt-repository ppa:ffmulticonverter/stable
sudo apt-get update
sudo apt-get install ffmulticonverter

 

Ikonu pro spuštění aplikace najkdete v Menu > Zvuk a video > FF Multi Converter.

Pro správnou funkčnost je ještě třeba doinstalovat balíčky unoconv a imagemagick. Program je lokalizován do češtiny, slovenština prozatím chybí. Domovskou stránku projektu najdete na https://sites.google.com/site/ffmulticonverter/home.

Štítky , , .Záložka pro permanentní odkaz.

11 reakcí na FF – Multi Converter

  1. Julius říká:

    Po instalaci dle návodu mi to při pokusu o konverzi hlásí :
    Chybějící závislosti: unconv,imagemagick

    Díky za odpověď.

    • Satapouch říká:

      Článek jsem trochu aktualizoval, aby lépe ladil se současným vzhledem webu. Pro správnou funkčnost je ještě třeba doinstalovat balíčky unoconv a imagemagick (doplněno i do textu článku), pak vše funguje, jak má.

  2. kamowski říká:

    Na LM 18 (Ubuntu 16) to už cez tie ppa nenainštalujete
    Stiahnite si zdroj (source) z domovskej stránky:
    http://sourceforge.net/projects/ffmulticonv/files/
    rozbaľte
    v tomto adresári si otvorte terminál a zadajte:
    python3 setup.py install
    raz-dva sa vám to nainštalujete a spúšťač nájdete v Menu – Multimédiá

  3. alfi51 říká:

    Nejde mi to nainstalovat, píše mi chybu: modul Qt5 nebyl načten a v menu se mi to samozřejmě neobjevilo. Můžete popsat postup pro blbce? V 17.3 jsem to měl nainstalované, ale v 18 ani boha.
    Díky.

    • radějianonymně říká:

      Mint právě nemám v PC ale podobné problémy jsem měl pod Mintem s QT digiKamem a showFoto. Když jsem chtěl mít poslední verze programů s novými funkcemi a s posledními opravami chyb.
      Tady v Mint 17.3 jsi ještě měl KDE4 (a tak nějak tomu odpovídal obsah repozitářů) ale v 18 si to má hrát už na KDE5 a, také, aktualizovaná stránka programu a o který ti jde píše: „… The application is written in Python3 and PyQt5… “ kdežto tento článek a z roku 2012 se odkazuje na ještě PyQT4, to pokud nebude článek už třeba dnes v tomto místě upraven.
      Tudíž příčiny potíží hledej někde zde. Tedy nesoulad mezi tím co chce v nárocích na QT právě program a co máš v Mintu resp. v odkazovaných repozitářích a které jsi i třeba dodatečně doplnil. Tedy jinak, je zmatek v závislostech a v tom kterou verzi programu chystáš spustit nebo nainstalovat .
      Asi před těmi více než 2 roky to bylo v Mintu a který se „zpožďoval“ s QT knihovnami i proti Ubuntu až neřešitelné, dosavadní návody přestaly fungovat. Mint to nakonec šalamounsky „vyřešil“ tak, že aby digiKam byl jako takový formálně dostupný a funkční, tak provedl v repozitáři významnou zpětně degradaci digiKamu a na nějaký echt dřevní stav dávné verze, protože měl staré QT knihovny. Což ovšem mým nárokům velmi tehdy nevyhovovalo.
      Tady co se ptáš podstata problému bude, jak píšu o něco výše, asi stejná i když v provedení a tedy cesty k řešení budou různé. Ono a také už jsem vzácně narazil na podobné problémy jinde a nejen v odlišnostech QT knihovem mezi KDE4 a KDE5, ale v rámci KDE5 mezi 5.6 a 5.7 a 5.8, a Mint 18 tuším že je stavěný na 5.6 … a také další třeba drobnost, pokud nejedeš přímo stažený Mint KDE tak se mohou knihovny v prioritách tlouct třeba s verzemi pro Mint Xfce, když některé KDE aplikace tam instaluješ dodatečně.
      Také se může stát, že správce balíčků/repozitáře po nahlášení tento zádrhel brzy spraví, tedy ještě dej nějaký google, odzkus konkrétní rady a potom chyby nahlaš.

      • radějianonymně říká:

        dodatek obecně z mateřského webu a platí to pro upgrade na verzi 1.8.0 a právě PyQt5 port:
        If you have upgraded from a previous version of FF Multi Converter you will need to remove your settings file,
        otherwise you’ll get an error. Please, remove: ~/.config/ffmulticonverter/FF\ Multi\ Converter.conf
        Pod Manjaro jsem právě nainstaloval 1.8.0-1 a bez problému se spouštěním.
        No a pro Ubuntu (mohlo by být podobně pro Mint) mateřský web hlásí že je to právě s repozitářem bezprizorní:
        There used to be a PPA that was usable, but it’s not available anymore. We’d appreciate help packaging this if anyone’s interested.

  4. alfi51 říká:

    Odstranil jsem ffmulticonverter z config, nainstalovalo se mi to a objevilo v Menu, ale po kliknutí na odkaz se nic neděje, nespustí se mi to.

    • radějianonymně říká:

      Tak ještě zalaboruj s verzemi programu, ta zcela nová je pro QT5 a ty starší předpokládám že pro QT4, třeba se nějaká verze chytne:
      https://sourceforge.net/projects/ffmulticonv/files/

      To, že na mateřském webu píšou ve smyslu o tom že repozitář pro Ubuntu zmizel a já to neověřoval, také může znamenat že se tak stalo důvodně právě pro problémy na které jsi i ty narazil a jejichž původ může být v tom, co jsem popisoval.
      Nejschůdnější cesta by byla kdyby někdo poučený a toho schopný (já jsem také laik jako ty) ten program po rezebrání příčin a v nějak funkčním kompromisu přeložil a balíček umístil do repozitáře přímo Mintu/Ubuntu.

  5. alfi51 říká:

    Tak bohužel ani jedna verze mi nejede. Vytvoří odkaz v Menu, ale nejde spustit

    • radějianonymně říká:

      Tak ještě připomínám, že je nutno doinstalovat ty další věci a jestli jsi na to nezapomenul. Viz závěr článku. Já pod Manjaro musel doinstalovat jen to unoconv.
      Pro mne tento článek a tvůj vstup/dotaz byl upozorněním na zajímavý program který odzkouším a protože mně dosud chyběl. Zatím jsem to vždy řešil náhodně vybranými službami nabízenými přes internet … a což nemusí být právě ideální.
      Řekl bych že tvůj právě problém je jistou nepříjemnou daní za ono povýšení Mintu v případě KDE a tedy QT knihoven do 5 řady a že čas to spraví. Jestli ti na tom hodně záleží a chceš zůstat u Mintu, jako že asi ano, tak o důvod více vrátit se k verzi 17.3 a čekat za bukem co dál. Možná tady ale ještě někdo s řešením přijde?

  6. alfi51 říká:

    Návrat k LM 17.3 Cinnamon opět jede ffmulticonverter. Nainstaloval jsem i Curlew, ale starší verzi. Nejnovější verze požadovala Python5.