Jak nainstalovat kernel 4.3 v Linux Mintu

kernel1

Po dvou měsících vývoje oznámil Linus Torvalds v pondělí v podvečer vydání linuxového jádra 4.3. V nové verzi stable kernelu je cca 11.000 korekcí od více než 1500 vývojářů, velikost patchů je 42 MB (změněno je 10388 souborů, přidáno 643628 řádků kódu, odstraněno je jich 333888). Asi 48% změn v kernelu 4.3 se týká ovladačů zařízení, přibližně 18% souvisí s aktualizací kódu pro hardwarové architektury, 11% se týká síťového provozu, 3% souborových systémů a asi 4% souvisí se subsystémy uvnitř jádra.

Více se o změnách a novinkách v kernelu 4.3 dozvíte v oficiálním oznámení.

Chcete-li si tedy toto nejnovější stabilní jádro nainstalovat i v našem Linux Mintu, pak čtěte dál….

Jelikož se všechny potřebné .deb balíčky nacházejí v repozitáři kernel.ubuntu.com, je instalace jádra 4.3 v Linux Mintu poměrně snadná. Postupujte přesně podle pokynů pro architekturu, na níž je postaven váš počítač. To, zda máte 32-bitový (i686) nebo 64-bitový systém, zjistíte buď v Nastavení systému > System Info nebo zadáním tohoto příkazu v terminálu:

Příkaz terminálu:
uname -m

 

Upozorňuji vás, že aktualizace jádra v Linux Mintu je sice poměrně jednoduchá záležitost, vyžaduje však pokročilé znalosti systému a provádíte jí vždy na vlastní nebezpečí!

 

Instalace jádra 4.3 v 32-bitové verzi Linux Mintu

Opět použijeme příkaz „vše v jednom“. Vše budeme provádět pomocí terminálu, tak si jej otevřete a zadejte:

Příkazy terminálu:
cd /tmp; wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.3-wily/linux-headers-4.3.0-040300_4.3.0-040300.201511020949_all.deb http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.3-wily/linux-headers-4.3.0-040300-generic_4.3.0-040300.201511020949_i386.deb http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.3-wily/linux-image-4.3.0-040300-generic_4.3.0-040300.201511020949_i386.deb; sudo dpkg -i *.deb

 

Instalace jádra 4.3 v 64-bitové verzi Linux Mintu

V terminálu zadejte:

Příkazy terminálu:
cd /tmp; wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.3-wily/linux-headers-4.3.0-040300_4.3.0-040300.201511020949_all.deb http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.3-wily/linux-headers-4.3.0-040300-generic_4.3.0-040300.201511020949_amd64.deb http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.3-wily/linux-image-4.3.0-040300-generic_4.3.0-040300.201511020949_amd64.deb; sudo dpkg -i *.deb

Restartujte počítač a nové jádro by mělo být aktualizované. Pokud vám z nějakého důvodu nenajede, restartuje počítač, v menu GRUBu vyberte  staré funkční jádro a to nové odstraňte níže uvedeným příkazem:

Příkaz terminálu:
sudo apt-get purge linux-image-4.3.0-*

 

Sám jsem otestoval tento nejnovější stabilní kernel na Linux Mintu 17.2 Rafaela s pracovním prostředím Mate, kde s mou hardwarovou konfigurací běhá naprosto bez problémů. V komentářích rád uvítám i vaše poznatky z instalace nového stabilního jádra do jiných verzí Linux Mintu.

Přeji hodně úspěchů při instalaci i práci s nejnovějším stabilním kernelem 4.3.

 

Štítky , , , , , , , .Záložka pro permanentní odkaz.

25 reakcí na Jak nainstalovat kernel 4.3 v Linux Mintu

  1. kamowski říká:

    tak som to riskol
    pri inštalácii vypisovalo nejaké chyby v súvislosti s ndiswrapper a s virtualboxom ale virtualbox v. 5.0.8 r103449 funguje
    myslím, že to bola najčastejšie popisovaná chyba predchádzajúcich kernelov

  2. Martin říká:

    už by sa zišiel nejaký návod ako hromadne odinštalovať staré jadrá 😉

    • kamowski říká:

      kolektívne tresty, kolektívne vyjednávanie, hromadná doprava, hromadné ….
      s tým by som bol opatrný 😀
      ty si možno vieš nastaviť parametre takéhoto „hromadného“ úkonu ale nie každý. z toho by bolo viac škody ako osohu, niečo ako pri bleachbit
      Správca aktualizácií – Linuxové jadrá – zvolím si z nainštalovaných a dám odstrániť
      nie je to na jedno kliknutie ale zvládnem to aj ja a nenapácha zbytočné škody 🙂

      • kamowski říká:

        edit:
        Správca aktualizácií – Zobraziť – Linuxové jadrá – zvolím si z nainštalovaných a dám odstrániť

  3. René Frick říká:

    skusali ste niekto virtualbox? nebude problem s dkms/gcc?

  4. René Frick říká:

    Unpacking linux-image-4.3.0-040300-generic (4.3.0-040300.201511020949) …
    Setting up linux-headers-4.3.0-040300 (4.3.0-040300.201511020949) …
    Setting up linux-headers-4.3.0-040300-generic (4.3.0-040300.201511020949) …
    Examining /etc/kernel/header_postinst.d.
    run-parts: executing /etc/kernel/header_postinst.d/dkms 4.3.0-040300-generic /boot/vmlinuz-4.3.0-040300-generic
    Error! Bad return status for module build on kernel: 4.3.0-040300-generic (x86_64)
    Consult /var/lib/dkms/ndiswrapper/1.59/build/make.log for more information.
    Error! Bad return status for module build on kernel: 4.3.0-040300-generic (x86_64)
    Consult /var/lib/dkms/virtualbox-guest/4.3.10/build/make.log for more information.

  5. Asen Ovčarov říká:

    Jak jsem psal minule, mohou být problémy s virtualboxem a některými drivery nvidie, protože kompilátor GCC začíná být zastaralý

    • Bedňa říká:

      A hlavne ten návod je nebezpečný a komplikuje identifikáciu problému.

      • Satapouch říká:

        Příteli, slovo nebezpečný už je silné i na mě. Když už, tak RIZIKOVÝ, ostatně jako každý zásah do kernelu, na což je však uživatel dost výrazně upozorněn hned na začátku. Navíc je určen pokročilým uživatelům, u kterých se předpokládá, že ví co dělají.
        Vím (byť nechápu proč), že mě nemusíš, ale přecházet až na takovou úrověň komentářů bys opravdu nemusel.

        • Bedňa říká:

          Prechod na novšiu verziu nieje vôbec nebezpečný, stále si pri boote môžeš vybrať starý kernel a väčšinou to bootne v poriadku, je pravda že tie uzatvorené šmejďárny s tým môžu mať problém, ako NVidia & CO.

          Za nebezpečný považujem príkaz

          sudo dpkg -i *.deb

          Za lepšiu identifikáciu problému považujem nedať príkaz do jedného oddeleného && alebo ; toto zhoršuje identifikáciu problému, už som tu na to upozorňoval.

          Takže sa horšie identifikuje, či sa niečo len nestiahlo, alebo nenainštalovalo. Rozpísať to do jednotlivých príkazov s popisom len príjme užívateľov sa vzdelávať.

          Príkaz

          sudo dpkg -i *.deb

          Ma úplne irituje, páč do /tmp má prístup každý a omylom sa tam môže dostať aj to čo by nemalo, minimálne ako som už prv pri inom jadre doporučoval, treba zmazať všetky balíčky v /tmp

          rm /tmp/*.deb

          Maj na mysli Hippokratovu prísahu, keď nevieš pomôcť, tak neublíž.

          Nieje to nič osobné.

          • Satapouch říká:

            Nezbývá mi, než po x-té zde zopakovat: článek je určen pro POKROČILÉ uživatele, kteří vědí, co který příkaz znamená a tehdy i čím může ublížit. Pokud se do upgradu kernelu pustí začátečník ve fungujícím systému, tak to se na mě nezlob, ale to je nezodpovědný hazardér. Dům se přece také staví od základů a nikoliv od střechy. 🙂

        • Bedňa říká:

          Teda musím ti napísať, že si tu odviedol kopec skvelej práce, ale proste mi nedá neupozorňovať na takéto závažné problémy. Dnes kopec ľudí stále viac a viac rieši veci cez internet a toto je diera ako prase. kľudne si o tom môžeme pokecať.

          No a kopec ľudí robí kopy paste pretože ti verí a nemusí to dopadnúť dobre.

          S priateľským pozdravom Bedňa.

  6. juhele2014 říká:

    Zdá se, že na této verzi vychytali problémy s usb, připojená zařízení jsou téměř okamžitě k dispozici. Na noťasu HP 650 probook připojuji dvbt flešku a všechno funguje na 100%. Testováno v programu VLC, Kaffeine. Co se týká celkové „rychlosti“ práce s ntb (odezva programů), nepozoruji změnu k horšímu. Skore v glmark2 je 1337.

  7. broukal říká:

    Tak to vyzera ze sa nedostanem z jadra 4.1….
    Nastavuje sa balík linux-headers-4.3.0-040300-generic (4.3.0-040300.201511020949) …
    Examining /etc/kernel/header_postinst.d.
    run-parts: executing /etc/kernel/header_postinst.d/dkms 4.3.0-040300-generic /boot/vmlinuz-4.3.0-040300-generic
    Error! Bad return status for module build on kernel: 4.3.0-040300-generic (x86_64)
    Consult /var/lib/dkms/vboxhost/4.3.30/build/make.log for more information.
    Error! Bad return status for module build on kernel: 4.3.0-040300-generic (x86_64)
    Consult /var/lib/dkms/nvidia-346/346.96/build/make.log for more information.

    • skorpionking říká:

      zkus jadro 4.2.3 tam mi nvidia funguje, ale mozna bude treba provest upgrade virtualboxu na verzi 5

      • broukal říká:

        No to jadro co spominas je nestabylne takze ho nejdem skusat vyberam si iba zo stabylnych jadier, posledne stabilne jadro ktore ide na mojich ovladacoch je 4.1.2. Skusyl som vsetky stabylne ostatne po nom a nejdu toto som zazil pri jadre 3.13 a musel som cakat lez sa na ubuntu uvolnili novise ovladace ktore fungovali az do teraz…

  8. Dejmon říká:

    Tak mi to také běží s udávanými chybami jako René Frick, akorát s tím rozdílem, že já mám AMD, Předchozí dvě řady 4.1 a 4.2 sly nainstalovat, ale problém byl a broadcomem a wifi nešla připojit. Železo jako vždy, kdo hledá najde. Noťas HP …..

    • Satapouch říká:

      A co kdyby ses podělil o to své hledání i s ostatními, třeba by to mohlo pomoci i někomu s obdobným problémem. Když se totiž řekne A, je nutné říci i B.

  9. TOmas Kral říká:

    takze poslední jádro, na které aktuální gcc stačí, je 4.2.3, potom těžko specifikovatelné problémy ?

    • skorpionking říká:

      to nevím nainstaloval jsem nejnovejsi gcc a stejne se mi nvidia nechyta tak jsem zustal na 4.2.3

      • TOmas Kral říká:

        zajímavé – 4.2.3 mi také funguje bez problémů, zkusil jsem dnes 4.2.6 a nebylo možné zkompilovat modul na virtualbox… jestli jsou ty problémy navázány na více věcí a defacto tedy 4.2.4+, tak 4.2.3 je ‚poslední‘ hladce funkční jádro pro Mint 17.2

  10. kamowski říká:

    kernel 4.3.0-040300-generic #201511020949
    virtualbox 5.0.8 r103449
    LM17.2 xfce 32bit
    žiaden problém
    tie problémy, ktoré popisujete máte na 64bit strojoch?

    • TOmas Kral říká:

      ano 64b, na začátku jsi psal, že ti to hází chyby taky na kompilaci vbox modulu, ale pak vbox funguje, respektivě asi naběhne a tváří se ok. To ale taky neni uplně dobř e, kdo ví v jaké situaci se ti to projeví …

  11. michalrotter říká:

    nic si nezapamatuje a kazdy start i restart zacinam odnova. mel sem w8.1 na nic se neptal cele pc vymazal a nefunguje.nevim jak instalovat jakikoli progr. po stazeni. mam lenovo 1T 64bit