Jak nainstalovat kernel 4.2.5 v Linux Mintu

kernel1

Jen čtyři dny od vydání linuxového jádra 4.2.4 oznámil Greg Kroah-Hartman v časných ranních hodinách 26. října 2015 vydání páté aktualizace linuxového jádra větve 4.2.

Linux kernel 4.2.5 je poměrně malá aktualizace. Většina změn v linuxovém kernelu 4.2.5 se týká aktualizací ovladačů GPU, zejména pro grafické karty AMD, ale nechybí ani oprava Nouveau, open-source ovladače grafických karet NVIDIA. Kromě došlo také k vylepšení architektur ARM, ARM64, SPARC a x86, stejně jako souborových  systémů Btrfs a NFS a různé další aktualizace ovladačů, zejména pro I2C, MD, MFD, PINCTRL.

Co se týká sítí, i zde má linuxový kernel 4.2.5 několik změn, a to zejména pro Dynamic Spectrum Access (DSA), IPv6, IPv4, Layer Two Tunneling Protocol (L2TP), Netlink, Open vSwitch, sunrpc a transparentní komunikaci mezi procesy (TIPC).  Uživatelům větve 4.2 je proto doporučeno aktualizovat.

Kompletní seznam změn a novinek v kernelu 4.2.5 najdete v changelogu.

Chcete-li si tedy toto nejnovější stabilní jádro nainstalovat i v našem Linux Mintu, pak čtěte dál….

Jelikož se všechny potřebné .deb balíčky nacházejí v repozitáři kernel.ubuntu.com, je instalace jádra 4.2.5 v Linux Mintu poměrně snadná. Postupujte přesně podle pokynů pro architekturu, na níž je postaven váš počítač. To, zda máte 32-bitový (i686) nebo 64-bitový systém, zjistíte buď v Nastavení systému > System Info nebo zadáním tohoto příkazu v terminálu:

Příkaz terminálu:
uname -m

 

Upozorňuji vás, že aktualizace jádra v Linux Mintu je sice poměrně jednoduchá záležitost, vyžaduje však pokročilé znalosti systému a provádíte jí vždy na vlastní nebezpečí!

 

Instalace jádra 4.2.5 v 32-bitové verzi Linux Mintu

Opět použijeme příkaz „vše v jednom“. Vše budeme provádět pomocí terminálu, tak si jej otevřete a zadejte:

Příkazy terminálu:
cd /tmp; wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.2.5-wily/linux-headers-4.2.5-040205_4.2.5-040205.201510270124_all.deb http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.2.5-wily/linux-headers-4.2.5-040205-generic_4.2.5-040205.201510270124_i386.deb http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.2.5-wily/linux-image-4.2.5-040205-generic_4.2.5-040205.201510270124_i386.deb; sudo dpkg -i *.deb

 

Instalace jádra 4.2.5 v 64-bitové verzi Linux Mintu

V terminálu zadejte:

Příkazy terminálu:
cd /tmp; wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.2.5-wily/linux-headers-4.2.5-040205_4.2.5-040205.201510270124_all.deb http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.2.5-wily/linux-headers-4.2.5-040205-generic_4.2.5-040205.201510270124_amd64.deb http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.2.5-wily/linux-image-4.2.5-040205-generic_4.2.5-040205.201510270124_amd64.deb; sudo dpkg -i *.deb

Restartujte počítač a nové jádro by mělo být aktualizované. Pokud vám z nějakého důvodu nenajede, restartuje počítač, v menu GRUBu vyberte  staré funkční jádro a to nové odstraňte níže uvedeným příkazem:

Příkaz terminálu:
sudo apt-get purge linux-image-4.2.5-*

 

Sám jsem otestoval tento nejnovější stabilní kernel na Linux Mintu 17.2 Rafaela s pracovním prostředím Mate, kde s mou hardwarovou konfigurací běhá naprosto bez problémů. V komentářích rád uvítám i vaše poznatky z instalace nového stabilního jádra do jiných verzí Linux Mintu.

Přeji hodně úspěchů při instalaci i práci s nejnovějším stabilním kernelem 4.2.5.

 

Štítky , , , , , , , , .Záložka pro permanentní odkaz.

27 reakcí na Jak nainstalovat kernel 4.2.5 v Linux Mintu

  1. René Frick říká:

    kurnik…aj tu je problem s virtualboxom. vypoise chybu, ze treba nanovo skompilovat. ked to pustim:
    —————————————————–
    sudo /etc/init.d/vboxdrv setup
    Stopping VirtualBox kernel modules …done.
    Uninstalling old VirtualBox DKMS kernel modules …done.
    Trying to register the VirtualBox kernel modules using DKMSError! Bad return status for module build on kernel: 4.2.5-040205-generic (x86_64)
    Consult /var/lib/dkms/vboxhost/5.0.2/build/make.log for more information.
    …failed!
    (Failed, trying without DKMS)
    Recompiling VirtualBox kernel modules …failed!
    (Look at /var/log/vbox-install.log to find out what went wrong)
    ——————————————————————-

  2. René Frick říká:

    preco sa pri odinstaluvavani 4.2.4 alebo 4.2.5 odinstaluje aj 4.2.3?

    • Allconius říká:

      Já jsem postupně odebral 4.2.4 i 4.2.5 a 4.2.3 mi zůstalo, záleží jak jsi to dělal. Správný postup je restart a v grubu vybrat jádro 4.2.3 a pak jít do správce aktualizací a tam odebrat 4.2.4 nebo 4.2.5 nebo oboje

  3. René Frick říká:

    teraz uz neviem ani 4.2.3 nainstalovat. pri instalacii vypise chybu:
    …..
    Examining /etc/kernel/header_postinst.d.
    run-parts: executing /etc/kernel/header_postinst.d/dkms 4.2.3-040203-generic /boot/vmlinuz-4.2.3-040203-generic
    Error! Bad return status for module build on kernel: 4.2.3-040203-generic (x86_64)
    Consult /var/lib/dkms/i915-3.16-3.13/1/build/make.log for more information.
    Error! Bad return status for module build on kernel: 4.2.3-040203-generic (x86_64)
    Consult /var/lib/dkms/virtualbox-guest/4.3.18/build/make.log for more information.
    Setting up linux-image-4.2.3-040203-generic (4.2.3-040203.201510030832) …
    Running depmod.
    ……

  4. Milhouse říká:

    Vytvoř vlákno na fóru, ať to tu je přehledné a dodej tam výpisy obou log souborů z odinstalace. A zároveň výpis místa na disku „df -Th /“

  5. Bedňa říká:

    Inak už minule som upozorňoval na nebezpečnosť príkazu

    sudo dpkg -i *.deb

    Rozhodne to ostalo nepovšimnuté.

    • Allconius říká:

      já to tímhle příkazem dělám vždycky 🙂 akorát si kontroluju obsah toho adresáře nad kterým to zadávám, aby tam nebyl i nějakej jinej *.deb třeba z předchozí verze jádra 😀

      • Bedňa říká:

        To robíš moc dobre. Len väčšina užívateľov bezhlavo kopíruje príkazy z internetu bez toho aby tušili čo vlastne robia.

        Ľudí teba vzdelávať aj na takýchto banalitách. No a na budúce tam trebárs pridať nejaký neškodný hack, ktorý napr raz za minútu vyhodí cez obrazovku smajla, aby si ľudia uvedomili ako sú takéto postupy nebezpečné.

        Taký malý základ, pokiaľ vidím niekoľkoriadkový príkaz bez jediného vysvetlenia a nechápem čo robím, tak to proste nikdy nespúšťam. Hodil by sa výkričník, ale ja nerád kričím.

        • Allconius říká:

          Přitom je to tak jednoduché. Když vím co dělám tak to dělám na PC. Když nevím co dělám tak to dělám na virtuálu ve virtualboxu 😀 Tenhle postup mě zatím nezklamal 🙂

  6. wondon říká:

    Zdravím všechny pokusníky.
    Opět potíže u jader 4.2.4 a 4.2.5 s vytvořením modulů pro virtualbox a nvidia, nevzdal jsem se a řádně si pročetl co píší v logu : cc: error: unrecognized command line option ‘-fstack-protector-strong’ . tak jsem neváhal a zjistil, že za vším je compiler GCC instalovaný v aktuelní versi 4.8. A to se nelíbilo. Přidal jsem si repozitář “PPA for Ubuntu Toolchain Uploads (restricted)” team, kde se nachází překladač ve versi 5.1. A hle veškeré potíže s novými jádry zmizeli. Nemáte zač a přeji pěkné pokusování s nejnovějšími jádry 🙂

  7. Asen Ovčarov říká:

    ppa:ubuntu-toolchain-r/test stačí zagooglovat. Už vydali aktualizaci gcc na 5.2

  8. Sante říká:

    No, mě ten repozitář nefunguje. Hlásí mi to chybu a že jsou některé balíky zastaralé.

  9. Sante říká:

    W: Selhalo stažení http://dists/https://launchpad.net/~ubuntu-toolchain-r/InRelease

    W: Selhalo stažení http://dists/https://launchpad.net/~ubuntu-toolchain-r/Release.gpg Nelze přeložit „dists“

    W: Některé indexové soubory se nepodařilo stáhnout. Jsou ignorovány, nebo jsou použity starší verze.

  10. Sante říká:

    Tohle to mi to vypíše. Nevim tedy kde je chyba?

  11. radekhodal říká:

    pád cinamonu

  12. Ukomír říká:

    Mne sa ho podarilo aktualizovať na verziu 5.2,ale mám aj verzie 4.8 a 4.9 a nejdú mi odinštalovať.Respektívne s ich odstránením by mi odstránilo aj nvidia,mint-mate..nejakých 14 položiek.U mna 4.2.5 síce ide,ale bez Nvidia 355 a prepínanie grafík.
    LMmate,4.2.3,

    • Asen Ovčarov říká:

      Ty starší je nutný tam nechat. Ubunťáci už pro Trusty zřejmě aktualizovat GCC nebudou a tento repozitář je jen testovací a vhodný jen pro ty, co chtějí mít nejnovější jádro. Instalovat z tohoto repozitáře „jen tak“ nedoporučuji

      • Allconius říká:

        Mě to nepomohlo, stále mám černou obrazovku, musel jsem dát z5 jádro 4.2.3

        • René Frick říká:

          ja po reinstalacii mam 3.13 a v nenasiel som rozdiel medzi 3.13 a 4.2.3, ktoru som mal naposledy (kym som si to dodrbal 🙂 )

  13. ukomír říká:

    Ani v kernel 4.3.0 nejde nvidia 355