Pidgin + Skype >> skype4pidgin plugin

pidginskypeV tomto príspevku som popísal inštaláciu pluginu pre pripojenie k chatu na Facebooku.
Teraz si popíšeme ďalší plugin, ktorý nám umožní pripojiť sa na chat s priateľmi, ktorý využívajú Skype.

V synapticu máme síce balíček pidgin-skype, ktorý toto umožňuje ale vyžaduje si aj inštaláciu samotného Skype. Pri komunikácii s priateľmi tak máme okrem Pidginu spustený aj Skype a … no je to také „nešťastné riešenie“.

Oveľa lepším riešením sa mi zdá plugin skype4pidgin, ktorý umožňuje komunikovať pomocou HTTP.
Tak si niečo povieme o jeho inštalácii, ktorá opäť nie je taká jednoduchá, ako by človek očakával.

Celkom na začiatku si musíme do „kuchyne“ zabezpečiť niekoľko „ingrediencií“. Najjednoduchšie to bude pomocou terminálu (Ctrl+Alt+T):

Příkazy terminálu:
sudo apt-get install libglib2.0-dev libjson-glib-dev libpurple-dev git

 

Stiahneme si nejaké tie „suroviny“ a skúsime z toho niečo ukuchtiť (kompilovať). Opäť použijeme terminál:

Příkazy terminálu:
git clone git://github.com/EionRobb/skype4pidgin.git
cd skype4pidgin/skypeweb
make
sudo make install

 

Takže teraz, keď sme všetko „ukuchtili“ bez chybovej hlášky, zdá sa, že máme plugin nainštalovaný.
Ale ….
LM17.2 obsahuje Pidgin s libpurple 2.10.9 a k využitiu tohoto pluginu potrebujeme 2.10.11. Toto si zabezpečíme pridaním ppa:

Příkazy terminálu:
sudo add-apt-repository ppa:pidgin-developers/ppa
sudo apt-get update
sudo apt-get install pidgin
sudo apt-get upgrade

 

Teraz by sme mali mať všetky náležitosti k „slávnostnému stolovaniu“.
Ale …,
áno, opäť jedno ale.
Neviem prečo, ale aj keď Pidgin sa tvári ako  2.10.11, stále je Skype účet nedostupný a je tam chybová hláška. Našťastie, riešenie je už jednoduché. Po chvíli sa hlási „Správca aktualizácii“ s novou verziou Pidginu. Po aktualizácii je všetko funkčné.
V Pidgine si  pridáme účet Skype (Účty-Spravovať účty-Pridať)
skypeHTTP

 

a môžeme s priateľmi komunikovať.

***

>>>  Postup pre LM 18.x

***

Štítky , , , .Záložka pro permanentní odkaz.

14 reakcí na Pidgin + Skype >> skype4pidgin plugin

  1. Henry říká:

    Super, vše funguje přesně podle návodu, včetně ‚Po chvíli sa hlási „Správca aktualizácii“ s novou verziou Pidginu.‘ 🙂 Díky!

  2. luboš říká:

    Já to zprovoznil takto i na Debianu Jessie,akorát ppa zdroj jsem musel přidat ručně (našel jsem si ho na stránkách tohoto zdroje). Takže to funguje i na debianu 8.Přes terminál mi nešel příkaz:sudo add-apt-repository ppa:pidgin-developers/ppa,vyhazovalo mi to chybu že nezná příkaz apt-ap.

  3. kamowski říká:

    a taký manjaro linux ho má priamo v repozitári spolu s pluginom pre fb 😉

  4. Michal Stanke říká:

    Nebyl by i návod na přidání Telegramu?

  5. kamowski říká:

    Návod funguje aj v LM 18.2
    posledný odsek, ktorý začína „LM17.2 obsahuje Pidgin s libpurple 2.10.9….“ vynechajte, nie je potrebný

  6. Caine říká:

    Děkuji za návod, chat funguje a na rozdíl od „oficiálního“ Skypu for linux tu lze trochu upravit vzhled a písmo… ale nemohu spustit videohovor. Přes Konverzace > Multimedia jsou všechny tři možnosti (Audio, Video a Audio/Video hovor) jen zašedlé. Dělám něco špatně, nebo tato možnost prostě není u pluginu k dispozici?

    • kamowski říká:

      žiaľ, „chyba nie je vo vašom prijímači“
      od istej aktualizácie, to nefunguje
      používam to 1-2x za rok, tak si to ani veľmi nevšímam ale prišla práve tá 1. či 2. príležitosť a …., no, nepoteší

  7. Caine říká:

    To je blesková odpověď! Ještě jednou děkuju… Škoda, že jsem se nezeptal dřív rovnou u kováře, nemusel jsem ztratit odpoledne zbytečným googlováním u kováříčků 🙂

  8. fikejz říká:

    Dnes jsem to zkoušel v LM 18.2 (Mate) 4.8.0-53-generic a nejde mi přidat repozitář ppa:pidgin-developers/ppa pokus o přidání skončí chybovou hláškou: Nelze přidat PPA repozitář: “Toto PPA nepodporuje xenial“.

  9. Pingback:Pidgin + Skype >> skype4pidgin plugin v LM 18.x – Linux Mint CZ&SK

Napsat komentář

Vaše emailová adresa nebude zveřejněna.