Pidgin + facebook >> purple-facebook plugin

Print Friendly

pidginfacebook

Facebook prednedávnom zrušil možnosť pripájať sa na svoj chat cez protokol xmpp. Mnohí užívatelia linuxu a programu Pidgin isto škrípali zubami a isto im uniklo aj niekoľko vybraných slov.

Bol síce „spáchaný“ akýsi facebook messenger ale toto mi absolútne nevyhovuje a ako alternatívu som to rýchlo zavrhol.

Našťastie v linuxovej komunite je celkom dosť tých, čo sa tomu rozumejú a tak sa relatívne rýchlo objavilo riešenie. Toto prišlo v podobe nového pluginu pre Pidgin a síce purple-facebook.

edit: pár vecí sa zmenilo, tie pôvodné príkazy prepíšem novými, aby to bolo funkčné.
opäť budem čerpať zo stránky autora tohoto pluginu

A tu je postup na inštaláciu:
1) najprv musíme pridať jeden riadok do zdroja, ten však ešte nemáme, tak si ho musíme vytvoriť …..
– otvoríme si prehliadač súborov (nemo, caja, thunar, …) v ňom „Súborový systém“ a v ňom adresár /etc/apt/
– tu si klikneme pravým tlačidlom myši na adresár /sources.list.d a zvolíme „otvoriť ako správca“
zadáme heslo a
2) v adresári vytvoríme nový súbor, ktorý pomenujeme: jgeboski.list
stále máme otvoreného správcu súborov v režime root
3) otvoríme si tento nový súbor a zapíšeme doň riadok (copy-paste)
deb http://download.opensuse.org/repositories/home:/jgeboski/version ./
#tu si každý nahradí <version> svojou distribúciou podľa tejto tabuľky:

Release Name Release Version Version
Debian Jessie 8.0 Debian_8.0
Debian Wheezy 7.0 Debian_7.0
Ubuntu Vivid Vervet 15.04 xUbuntu_15.04
Ubuntu Utopic Unicorn 14.10 xUbuntu_14.10
Ubuntu Trusty Tahr 14.04 xUbuntu_14.04
Ubuntu Precise Pangolin 12.04 xUbuntu_12.04

#napr. tí, čo máme LM17.2, si to nahradíme za  xUbuntu_14.10 a zápis bude vyzerať takto:
deb http://download.opensuse.org/repositories/home:/jgeboski/xUbuntu_14.10 ./
uložíme Ctrl+S a zavrieme
zatvoríme aj správcu súborov
4) otvoríme si terminál Ctrl+Alt+T a zadáme nasledujúce príkazy:

Příkazy terminálu:
wget http://download.opensuse.org/repositories/home:/jgeboski/<version>/Release.key
wget -O- https://jgeboski.github.io/obs.key | sudo apt-key add –

#tu si opäť každý nahradí <version> svojou distribúciou

# v príkaze je veľké O, nie nula a na konci je obyčajná pomlčka
môže byť, že ju stránka skreslí, tak ju radšej v termináli zmažte a prepíšte

Příkazy terminálu:
sudo apt-key add Release.key

 

Příkazy terminálu:
rm Release.key

 

Příkazy terminálu:
sudo apt-get update

 

Příkazy terminálu:
sudo apt-get install purple-facebook

5) Spustite Pidgin a pridajte si účet pre facebook (Účty-Spravovať účty-Pridať)

fb

 

ten pôvodný cez xmpp vám nebude fungovať, môžete ho kľudne vymazať.

 

***
pre fanúšikov terminálu, zadajte postupne nasledovné príkazy:

Příkazy terminálu:
sudo su
echo deb http://download.opensuse.org/repositories/home:/jgeboski/version ./ > /etc/apt/sources.list.d/jgeboski.list
exit

#tu si každý nahradí <version> svojou distribúciou
potom:

Příkazy terminálu:
wget http://download.opensuse.org/repositories/home:/jgeboski/<version>/Release.key
wget -O- https://jgeboski.github.io/obs.key | sudo apt-key add –

#tu si každý opäť nahradí <version> svojou distribúciou

# v príkaze je veľké O, nie nula a na konci je obyčajná pomlčka
môže byť, že ju stránka skreslí, tak ju radšej v termináli zmažte a prepíšte

potom:

Příkazy terminálu:
sudo apt-key add Release.key
rm Release.key
sudo apt-get update
sudo apt-get install purple-facebook

 

Tí užívatelia, ktorí mali tento plugin nainštalovaný už skôr podľa pôvodného postupu a teraz sa im pri
sudo apt-get update zobrazuje chybová hláška v súvislosti s kľúčom, niečo ako
Zlyhalo … http://extra.linuxmint.com …
stiahnite a pridajte si ten kľúč a aktualizujte, čiže:
wget -O- https://jgeboski.github.io/obs.key | sudo apt-key add - | sudo apt-get update

Štítky , , , .Záložka pro permanentní odkaz.

34 reakcí na Pidgin + facebook >> purple-facebook plugin

  1. Profile photo of Pajus říká:

    Hoja, tak na toto jsem čekal dlouho 🙂 JÁ jsem take ten co skřípal zoubkama a nadaval že mi to nejede. Na Win7 jsem to opravil hned ale u Linuxu Mint až teď podle tohoto návodu. Vše teď funguje jak má takže DĚKUJI 🙂

  2. Vikina říká:

    Dobrý deň.
    Ďakujem za super článok, ale narazila som na problém 🙁 Neviem, kde nájsť purple-facebook plugin. V správcovi ani v synapticu som ho nenašla 🙁 Keď skúšam postup, tiež mi to nejde. Robím niečo zle? 🙁 ďakujem za radu 🙂 Vikina

    • kamowski říká:

      buď postupuj podľa bodov 1 až 5
      alebo si hneď otvor terminál a copy-paste tie príkazy na spodku článku, určené pre fanúšikov terminálu 🙂
      ale hlavne nezabudni prepísať v príkazoch „version“ ako na to upozorňujem v článku !!!

      • Vikina říká:

        Načítavajú sa zoznamy balíkov… Hotovo
        Vytvára sa strom závislostí
        Načítavajú sa stavové informácie… Hotovo
        E: Nedá sa nájsť balík purple-facebook

      • Vikina říká:

        Cez všetko som sa úspešne dostala, aj s verziou v pohode, ale po purple-facebook, sa asi zľahla zem… 🙂

        • kamowski říká:

          skús to ešte raz a keď sa dopracuješ k chybovej hláške, skopíruj sem obsah terminálu, nech vidíme, kde je chyba

    • kamowski říká:

      ak máš LM 17.2, zadaj tam postupne toto:
      sudo su

      echo deb http://download.opensuse.org/repositories/home:/jgeboski/xUbuntu_14.10 ./ > /etc/apt/sources.list.d/jgeboski.list

      exit

      wget http://download.opensuse.org/repositories/home:/jgeboski/xUbuntu_14.10/Release.key

      sudo apt-key add Release.key

      rm Release.key

      sudo apt-get update

      sudo apt-get install purple-facebook

      a keď dôjdeš k tej chybe, tak to sem celé nakopíruj

      • Profile photo of Klocek říká:

        zdravím
        děkuji za návod
        Bohužel, na konci mi to hodilo při instalaci purple-facebook tuto hlášku v terminálu.

        sudo apt-get install purple-facebook
        Čtu seznamy balíků… Hotovo
        Vytvářím strom závislostí
        Čtu stavové informace… Hotovo
        Následující balík byl nainstalován automaticky a již není potřeba:
        libsvga1
        Pro jejich odstranění použijte „apt-get autoremove“.
        Následující NOVÉ balíky budou nainstalovány:
        purple-facebook
        0 aktualizováno, 1 nově instalováno, 0 k odstranění a 29 neaktualizováno.
        Potřebuji stáhnout 0 B/78,2 kB archivů.
        Po této operaci bude na disku použito dalších 221 kB.
        (Čtu databázi … nyní je nainstalováno 242299 souborů a adresářů.)
        Rozbaluji purple-facebook (z …/purple-facebook_20151018~a418f60~6a0a79182ebc~24_i386.deb) …
        dpkg: chyba při zpracovávání /var/cache/apt/archives/purple-facebook_20151018~a418f60~6a0a79182ebc~24_i386.deb (–unpack):
        zkouším přepsat soubor „/usr/lib/purple-2/libfacebook.so“, který je také v balíku pidgin-facebookchat 1.69-2ubuntu2
        Při zpracování nastaly chyby:
        /var/cache/apt/archives/purple-facebook_20151018~a418f60~6a0a79182ebc~24_i386.deb
        E: Sub-process /usr/bin/dpkg returned an error code (1)

        Všechny příkazy před tím „sudo apt-get install purple-facebook“ byly splněny v pořádku

        co s tím? 🙂

        děkuji

        • Profile photo of Klocek říká:

          sudo apt-get install -f
          toto:
          E: Nelze získat zámek /var/lib/dpkg/lock – open (11: Prostředek je dočasně nepřístupný)
          E: Nelze uzamknout administrační adresář (/var/lib/dpkg/). Používá jej jiný proces?

          sudo dpkg –configure -a
          toto:
          dpkg: chyba: potřebuji zadat akci

          Napište dpkg –help k získání nápovědy o instalaci a odinstalaci balíků [*];
          Pro uživatelsky přívětivou správu balíků použijte dselect nebo aptitude;
          Napište dpkg -Dhelp pro seznam ladících příznaků dpkg;
          Napište dpkg –force-help k získání seznamu vynucovacích přepínačů;
          Napište dpkg-deb –help k získání nápovědy o zacházení se soubory *.deb;

          Volby označené [*] produkují obsáhlý výstup – použijte „less“ nebo „more“!

          tak nevím co s tím….
          děkuji za nápomoc

          • Profile photo of Klocek říká:

            děkuji
            „Ten druhý príkaz je takto (akosi sa to spojilo): sudo dpkg –configure -a“
            Je stejný jako ten předchozí druhý….

            zkusil jsem všechny programy zavřít krom FF a terminalu a došlo ke změně.

            sudo apt-get install -f
            Čtu seznamy balíků… Hotovo
            Vytvářím strom závislostí
            Čtu stavové informace… Hotovo
            Následující balík byl nainstalován automaticky a již není potřeba:
            libsvga1
            Pro jejich odstranění použijte „apt-get autoremove“.
            0 aktualizováno, 0 nově instalováno, 0 k odstranění a 29 neaktualizováno.

            a
            sudo dpkg –configure -a
            dpkg: chyba: potřebuji zadat akci

            Napište dpkg –help k získání nápovědy o instalaci a odinstalaci balíků [*];
            Pro uživatelsky přívětivou správu balíků použijte dselect nebo aptitude;
            Napište dpkg -Dhelp pro seznam ladících příznaků dpkg;
            Napište dpkg –force-help k získání seznamu vynucovacích přepínačů;
            Napište dpkg-deb –help k získání nápovědy o zacházení se soubory *.deb;

            Volby označené [*] produkují obsáhlý výstup – použijte „less“ nebo „more“!

          • Profile photo of Klocek říká:

            u toho souboru /var/lib/dpkg/lock jsem změnil práva z ROOT na moje uživ.jméno(nevím, jestli je bezpečné ho veřejně vytrubovat). Udělal jsem to přes ROOTa
            Pak jsem vypl ty programy a pak znovu zadal ten první příkaz. Změnu jsem už napsal.

            Pokud se to spojí ty 2 pomlčky, tak jsem je zadal dvojitě a výsledek je tentýž.

            sudo dpkg –-configure -a
            dpkg: chyba: potřebuji zadat akci

            Napište dpkg –help k získání nápovědy o instalaci a odinstalaci balíků [*];
            Pro uživatelsky přívětivou správu balíků použijte dselect nebo aptitude;
            Napište dpkg -Dhelp pro seznam ladících příznaků dpkg;
            Napište dpkg –force-help k získání seznamu vynucovacích přepínačů;
            Napište dpkg-deb –help k získání nápovědy o zacházení se soubory *.deb;

            Volby označené [*] produkují obsáhlý výstup – použijte „less“ nebo „more“!

          • Profile photo of Klocek říká:

            sudo dpkg –configure -a
            neudělá nic…. 🙁

          • Profile photo of Klocek říká:

            ono se to už neptá na heslo, bo jsem pod ROOTem v terminálu. čili by to mělo být ok.

            Jinač právě purple-facebook nejde nainstalovat. Je to pro Pidgin, ne pro Skype

          • Profile photo of Klocek říká:

            chci se zeptat, je z těch hlášek něco zřejmé?

          • Profile photo of Klocek říká:

            zkouším ještě jednou celý postup s instalací. Hodilo mi to nyní tuto hlášku:

            sudo apt-get install purple-facebook
            Čtu seznamy balíků… Hotovo
            Vytvářím strom závislostí
            Čtu stavové informace… Hotovo
            Následující balík byl nainstalován automaticky a již není potřeba:
            libsvga1
            Pro jejich odstranění použijte „apt-get autoremove“.
            Následující NOVÉ balíky budou nainstalovány:
            purple-facebook
            0 aktualizováno, 1 nově instalováno, 0 k odstranění a 29 neaktualizováno.
            Potřebuji stáhnout 0 B/78,2 kB archivů.
            Po této operaci bude na disku použito dalších 221 kB.
            (Čtu databázi … nyní je nainstalováno 242299 souborů a adresářů.)
            Rozbaluji purple-facebook (z …/purple-facebook_20151018~a418f60~6a0a79182ebc~24_i386.deb) …
            dpkg: chyba při zpracovávání /var/cache/apt/archives/purple-facebook_20151018~a418f60~6a0a79182ebc~24_i386.deb (–unpack):
            zkouším přepsat soubor „/usr/lib/purple-2/libfacebook.so“, který je také v balíku pidgin-facebookchat 1.69-2ubuntu2
            Žádné apport hlášení nebylo vytvořeno, protože již byl dosažen MaxReports
            Při zpracování nastaly chyby:
            /var/cache/apt/archives/purple-facebook_20151018~a418f60~6a0a79182ebc~24_i386.deb
            E: Sub-process /usr/bin/dpkg returned an error code (1)

            Když se podívám do Synapticu, tak tam purple-facebook není.

  3. Vikina říká:

    Veľmi pekne ďakujem za trpezlivosť. Neviem, kde som robila chybu. Keď som kopírovala postup z článku, vždy bolo posledné hlásenie chybové, teraz sa to podarilo. Ešte raz ďakujem 🙂 Vikina

  4. jirka říká:

    děkuji jsi borec

    • kamowski říká:

      ďakujem ale nie som 🙂
      v treťom odstavci je odkaz na zdroj, odkiaľ som čerpal
      len som to trochu upravil a „vymaloval“ 😀
      ale hlavne, že to pomohlo (aj mne)

  5. kamowski říká:

    po aktualizácii 20150827 pidgin zobrazuje aj smajlíkov z FB
    pred tým to boli len odkazy, ktoré sa dali pozrieť iba prihlásením sa na FB cez web prehliadač
    takže plugin je opäť o veľký krok ďalej (aktualizuje sa takmer denne 🙂 )
    autorovi patrí vďaka

  6. Marecek říká:

    Zdravím vás ,
    postupoval som podla návodu p.kamowskeho a vypísalo mi to ku koncu tieto chyby :
    W: Zlyhalo stiahnutie http://extra.linuxmint.com/dists/rafaela/InRelease

    W: Zlyhalo stiahnutie http://extra.linuxmint.com/dists/rafaela/Release.gpg Nedá sa pripojiť k extra.linuxmint.com:http:

    W: Niektoré indexové súbory sa nepodarilo stiahnuť. Boli ignorované alebo sa použili staršie verzie.

    ako ďalej postupovať ? ďakujem za odpoveď.

  7. Profile photo of kamowskikamowski říká:

    Ten pôvodný kľúč je už nedostupný, návod som upravil.
    U mňa to funguje, tak by s tým nemal mať nikto problém 🙂

  8. Marecek říká:

    Ďakujem už to funguje 🙂

  9. kamowski říká:

    článok som písal tak, aby aj začínajúci užívateľ vedel, čo, kde a prečo robí
    tu je to ešte raz, už s novým zdrojom, príkazy pre terminál pre LM17:
    sudo su
    echo deb http://download.opensuse.org/repositories/home:/jgeboski/xUbuntu_14.10 ./ > /etc/apt/sources.list.d/jgeboski.list
    exit
    wget -O- https://jgeboski.github.io/obs.key | sudo apt-key add –
    #v tomto riadku je veľké písmeno O, nie nula a na konci je obyčajná pomĺčka
    sudo apt-get update
    sudo apt-get install purple-facebook

    áno, mohol som to napísať aj takto, užívateľ by urobil copy-paste, a je to
    ale ja som dral klávesnicu a niekoľko málo príkazov som „rozmazal“ do článku 😀

  10. Profile photo of Klocek říká:

    purple-facebook se mi opět v nabídce oběvil… zkusil jsem ho instalovat a dává mi to tuto hlášku:

    E: /var/cache/apt/archives/purple-facebook_20151018~a418f60~6a0a79182ebc~24_i386.deb: zkouším přepsat soubor „/usr/lib/purple-2/libfacebook.so“, který je také v balíku pidgin-facebookchat 1.69-2ubuntu2

    může mi někdo říct, co s tím mohu udělat? děkuji

    • Profile photo of Klocek říká:

      heh. zdá se, že problém jsem vyřešil. Odinstalovalem pidgin-facebookchat a pak již šlo nainstalovat purple-facebook . Konverzace se mi již zobrazují.

      • kamowski říká:

        určite užitočná informácia
        možno bude mať niekto podobný problém a toto mu pomôže
        ďakujem Klocek

  11. Petr říká:

    Kdybys byl ženská, tak Tě ojedu!! Díky 🙂

  12. Pingback:Linux Mint 18 “Sarah” – pred a po inštalácii (Cinnamon) - Linux Mint CZ&SK

  13. Pingback:Pidgin + Skype >> skype4pidgin plugin - Linux Mint CZ&SK

  14. Vario říká:

    Ten Linux je ale pakárna. Nejde mi to nic mi nejde. Mám Ubuntu Gnome kde jsem si nainstaloval Mate které používám. Dáš mi radu jak postupně toto rozjedu? Všude mám zamítnuty přístupy atp ač jsem root.

  15. Vario říká:

    Ještě dodavam mam verzi 16.04.2 LTS

  16. kamowski říká:

    pakárna? 😀 😀 😀
    ale no tak, to hádam nebude také hrozné 😀 😀 😀
    hneď nad tvojou otázkou je môj komentár s linkom na postup v LM18, čo je vlastne ubuntu 16.04
    tak to inštaluj podľa toho postupu

    k tým prístupom založ v primeranej sekcii na fóre nové vlákno, výstižne ho pomenuj a čo najpodrobnejšie popíš, čo sa deje/nedeje, kedy, ako,…

Napsat komentář

Vaše emailová adresa nebude zveřejněna.