Jak nainstalovat kernel 4.0.4 v Linux Mintu

kernel1

A po čtyřech dnech po vydání třetí aktualizace nejnovější stabilní větve linuxového kernelu byla v neděli vydána čtvrtá aktualizace s označením 4.0.4.

Jedná se opět o malou aktualizaci, která obsahuje opravy pro architekturu ARM, aktualizace pro zařízení ACPI, MMC, GPU (Radeon a Intel i915) a další vylepšení.

Kompletní seznam změn najdete v changelogu.

Chcete-li si tedy toto nejnovější stabilní jádro nainstalovat i v našem Linux Mintu, pak čtěte dál….

Jelikož se všechny potřebné .deb balíčky nacházejí v repozitáři kernel.ubuntu.com, je instalace jádra 4.0.4 v Linux Mintu poměrně snadná. Postupujte přesně podle pokynů pro architekturu, na níž je postaven váš počítač. To, zda máte 32-bitový (i686) nebo 64-bitový systém, zjistíte buď v Nastavení systému > System Info nebo zadáním tohoto příkazu v terminálu:

Příkaz terminálu:
uname -m

 

Upozorňuji vás, že aktualizace jádra v Linux Mintu je sice poměrně jednoduchá záležitost, vyžaduje však pokročilé znalosti systému a provádíte jí vždy na vlastní nebezpečí!

 

 

Instalace jádra 4.0.4 v 32-bitové verzi Linux Mintu

Opět použijeme příkaz „vše v jednom“. Vše budeme provádět pomocí terminálu, tak si jej otevřete a zadejte:

Příkazy terminálu:
cd /tmp && wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.0.4-wily/linux-headers-4.0.4-040004_4.0.4-040004.201505171336_all.deb http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.0.4-wily/linux-headers-4.0.4-040004-generic_4.0.4-040004.201505171336_i386.deb http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.0.4-wily/linux-image-4.0.4-040004-generic_4.0.4-040004.201505171336_i386.deb && sudo dpkg -i *.deb

 

2Instalace jádra 4.0.4 v 64-bitové verzi Linux Mintu

V terminálu zadejte:

Příkazy terminálu:
cd /tmp && wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.0.4-wily/linux-headers-4.0.4-040004_4.0.4-040004.201505171336_all.deb http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.0.4-wily/linux-headers-4.0.4-040004-generic_4.0.4-040004.201505171336_amd64.deb http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.0.4-wily/linux-image-4.0.4-040004-generic_4.0.4-040004.201505171336_amd64.deb && sudo dpkg -i *.deb

 

V této větvi kernelu by se již měla konečně provést aktualizace automaticky. Pokud tomu tak není, restartujte počítač a nové jádro by mělo být aktualizované.

Sám jsem otestoval tento nejnovější stabilní kernel na Linux Mintu 17.1 Rebecca s pracovním prostředím Cinnamon a na LMDE 2 Betsy s prostředím Mate, kde s mou hardwarovou konfigurací běhá naprosto bez problémů, avšak avizovaná funkce Life Patching mi stále nefunguje. V komentářích rád uvítám i vaše poznatky z instalace nového stabilního jádra do jiných verzí Linux Mintu.

Přeji hodně úspěchů při instalaci i práci s nejnovějším stabilním kernelem 4.0.4.

 

Štítky , , , , , , .Záložka pro permanentní odkaz.

19 reakcí na Jak nainstalovat kernel 4.0.4 v Linux Mintu

  1. romanos74 říká:

    Tak otestováno a absolutní spokojenost i v Glmarku2 nárůst o 300 bodů, vše jede jak má.

  2. Dejmon říká:

    4.*.*. maká bez problémů na čisté instalaci XFCE. Je ale zajímavé, že do verze 3.18.8 šlo kernel aktualizovat, ale pak už ne-eee, neustále to hlásilo chyby. Psal jsem to již tady, ale na jednu věc jsem poté přišel. Nedalo mi to, a na SSD jsem si nainstaloval různé instalace Linuxu a zkoušel s pokusy. Prostě po čisté instalaci šlo aktualizovat jakékoliv jádro, takže zakopaný pes bude někde jinde. Při provozu a pár aktualizací jádra už poté nechce !!!! se upgrade provést.

    Version-
    Kernel : Linux 4.0.4-040004-generic (x86_64)
    Compiled : #201505171336 SMP Sun May 17 17:37:22 UTC 2015
    C Library : Unknown
    Default C Compiler : GNU C Compiler version 4.8.2 (Ubuntu 4.8.2-19ubuntu1)
    Distribution : Linux Mint 17.1 Rebecca
    -Current Session-
    Desktop Environment : XFCE 4

  3. Barthezz říká:

    nevite prosimvas nekdo jak je to s tim lifepatchingem ? zase jsem musel rebootobat…

  4. Dejmon říká:

    Tak u mě Life Patching nefungoval, muselo dojít k restatu systému, aby došlo k načtení kernelu 4.0.4. Já sem tedy upgradoval z 3.13.* na 4.0.4

  5. Floyd říká:

    4.0.4 v Cinnamonu bez problému, také jsem musel rebootovat, v prostředí Kde proběhne celá instalace a po rebootu zůstavá staré jádro.

  6. Floyd říká:

    V LMDE 2 Betsy s prostředím Mate instalace bez problému, Life Patching nefunkční, 4.0.4 opět skvělé jádro.

  7. zbyna říká:

    Linux Mint 17.1 64bit. KDE, GeForce GTX 570, driver340.76
    funguje

  8. juhele2014 říká:

    Když připojím dvbt flešku, abych prubnul program GQRX, viz http://forum.linux-mint-czech.cz/viewtopic.php?f=25&t=1363 ,tak to nejde, napíše to hlášku, že modul je používaný (obsazený). Nové jádro 4.0.4 na tento sw (zatím) nelze použít.

  9. kamowski říká:

    LM 17.1 mate 32 bit na staršom pc hp-compaq-dc7100
    LM 17.1 mate, xfce 64 bit na staršom nb dell e6400
    crunchbang++ 1.0 64 bit na staršom nb dell e6400
    všetko OK

  10. radekhodal říká:

    proc mi od verze 4.0 at tam dam cokoli jakykoli kernel 4 a vyse nenajede pc, spadne jakoby do modre smrti a napise ze xserver selhal. nevi nekdo?

    • Kebab říká:

      už se tady ptáš po kolikáté a je to pořád stejné a zatím proto zbytečné, u jedné z minulých verzí jádra řady 4 máš odkaz na úspěšný pokus jak zprovoznit tvůj vlastně starý ovladač s novým jádrem a následovalo potvrzení že to fungovalo, pořád jsi proto nenapsal jak jsi dopadl ty a když už jsi více než 10 x dělal čistou instalaci … tak asi máš na to zkusit i tuto možnost když to jádro 4 tolik moc chceš, že?

  11. radekhodal říká:

    miluju linux. jen ptam se nevite proc mi to pri prechodu z kernelu 3xxxxxna kernel4xxxxxx nepusti dal nez do biosu a napise mi to neco o grafice ze x server selhal? mam gtx 295 nvidia a i7 875k mint 17 cinamon

    • Kebab říká:

      Když už ti to napsalo že x server selhal tak jsi se dostal dál než to, čemu se říká obvykle „nepustí dál než do biosu“ … a důvod tvých potíží moc dobře a dlouho znáš a přesto se umanutě tady ptáš pořád dokola a dokola na to samé: nVidia pro tvoji kartu nabízí stále jen starší ovladač 340.76 a s tím si řada 4 zatím nerozumí, přesto se některým podařilo jádro řady 4 zprovoznit i s tvým starším ovladačem a ty návody jsou známé a i zde na webu potvrzené že jim to tak funguje … pokud někde děláš pořád chybu nebo jsi se neodhodlal podle návodu postupovat tak si musíš počkat, použij vyhledávač a je kolem toho dostupné dost věcí abys byl dostatečně průběžně informován.

  12. Kebab říká:

    Po provedení dnešní nabídnuté aktualizace systému:
    program Správce aktualizací již v přehledu linuxových jader zobrazuje jádra řady 4 a je tedy opraveno!

    • Kebab říká:

      a s čím má co jakoby kdo vědět?
      Zadej si „spuštění serveru X selhalo“ do vyhledávače a vyjede ti celá hromada odkazů! Kde si můžeš potom počíst až do druhého dne, především a také podmínky(!) za kterých se tato hláška komu kde objevila.
      Ty o nich tady (o podmínkách) ale nepíšeš v tomto kratinkém dotazu ani slovo: přitom moc dobře a už vícero týdnů ty víš, co to je za hlášku.
      Je tedy záhadou proč zde a s prominutím pořád plevelíš s týmiž dotazy? Když odpověď přece už ty znáš a pokud je to v souvislosti s pokusem o instalaci jádra řady 4: tutéž hlášku jsem viděl i já, přes GRUB jsem proto musel natáhnout znovu systém s předchozím jádrem řady 3 a tam navolit přes Driver Manager novější(!) ovladač nVidia který však formálně nVidia nenabízí(!) pro tvoji starší kartu.
      To jsem ti také musel na počátku tvých dotazů zjistit a napsat až já, že novější ovladač neštymuje dle nVidia ke tvé staré kartě. Přitom v návodech, dle kterých jsi měl ty postupovat, tak zjištění věcí kolem ovladače u grafické karty mělo být přece jedno z prvních … ty jsi ho však nedodržel! A už od toho se odvíjí pořád táž tvá jakoby nechápavost a proč se zde proto pořád ptáš na to samé.
      Já jsem si svůj problém vyřešil. Mám novější kartu. Jak vyřešit tvůj problém aby i když krkolomně tvůj starší ovladač pracoval s řadou 4 je už ale také známé, buď se edituje jeden soubor nebo a jak jsem se v posledku dnes díval je dostupný i jakýsi patch.
      Pokud toho nejsi schopen sám, tak se ještě pokus spojit s někým osobně kdo už tuto úpravu pro starší ovladač provedl (když budeš pozorný tak v diskuzích k instalaci jader řady 4 byl/je minimálně jeden takový i zde na webu) … ale pokud nevíš co vlastně ty děláš a nevíš ani co je základní hláška na kterou se tu ptáš a abys cokoli dál uvedl,
      tak a protože máš komplikaci se starším hardwarem (grafickou kartou) tak pokus o instalaci jádra řady 4 je u tebe také komplikovaný a tím, že se tu pořád ptáš na to samé, to přece nevyřešíš.
      Já už za sebe ti toho zde napsal myslím dost, v dobrém úmyslu ti pomoci, ale už bych se mnohokrát opakoval protože se ptáš stále na totéž a na vícero místech … a tak raději končím 🙂

      • radekhodal říká:

        dekuju KEBAB za to ze me nakopl….jsem od prirody liny a chtel bych mit vsechno bez prace. tak se musim omluvit. vysledek meho snazeni je zde:

        https://plus.google.com/105451169965267962070/posts/2yMa2VcCbrD

        vse funguje jak ma…..navod jsem sebraz zde:

        https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-304-updates/+bug/1431278

        ale jak rikam nebyt kebaba tak bych se na to vykaslal. ale tento clovek mi slusne napsal at nejsem liny a jen nebrecim a hledam.

        Dekuji….mint umi i vychovavat……:-)

        • Kebab říká:

          Tak hurá a sláva že jsi to rozpohyboval. A dal také i ty pozitivní příklad ostatním!
          Teď už jde o to, já to nekoumal, že až vydají další jádro v pořadí 4.0.5 (ale platí to obecně) tak jestli tu krkolomnost navíc budeš muset pokaždé opakovat? Nebo se spokojíš a na delší dobu s jádrem co tam máš právě teď tj. 4.0.4.
          Osobně si myslím že toto je, zádrhel s těmi ovladači, věc která nemusela vůbec být a je proto podstatou zbytečná a jen to naštve protože v roce 2015 už na nějaké to pohodlí bez komplikací máme nárok: leckoho právě tyto věci mohou na Linuxu potom odradit, já podobné zádrhele měl nedávno nikoli s grafickou kartou ale po nevinné výměně digitálního fotoaparátu a, kdysi dávno před lety a to jsem zvědavě louskal Slackware, jsem nemohl zprovoznit jakýsi interní modem a tak jsem byl vůbec bez možnosti internetu … což Linux pro mne na nějaký ten rok (do výměny hardware) odepsalo zcela.

  13. radekhodal říká:

    dekuju za asertivitu a slusnost.