Jak nainstalovat kernel 4.0 v Linux Mintu

kernel1

Po několika měsících vývoje, anketě pro potvrzení nového číslování a sedmi RC verzích byl v pondělí konečně vydán nový stabilní linuxový kernel 4.0. Ten, mimo řady oprav, přináší i důležité změny. Mezi ty nejvýznamnější patří zejména nový způsob patchování, což je projekt vytvořený díky spolupráci mezi firmami RedHat a SUSE, díky němuž bude možné aktualizovat jádro, vkládat moduly, bezpečnostní záplaty apod. bez nutnosti restartu celého systému. Toto je zvláště vhodné u serverů, kdy bude možné provést bezpečnostní i údržbovou aktualizaci, aniž by se musel znovu restartovat systém, takže nebude nutné vypínat např. webové stránky, poštovní servery atd..

Linux 4.0 kromě toho přináší i podporu pro Intel Quark, TPM 2.0 a IBM z13, vylepšenou hardwarovou podporu pro notebooky Toshiba, Logitech HID++, stejně jako optimalizaci pro grafické karty AMD (podpora DisplayPort Audio), Intel a Nvidia.

Celou zprávu o vydání nového kernelu si můžete přečíst zde.

Chcete-li si tedy toto nejnovější stabilní jádro nainstalovat i v našem Linux Mintu, pak čtěte dál….

Jelikož se všechny potřebné .deb balíčky nacházejí v repozitáři kernel.ubuntu.com, je instalace jádra 4.0 v Linux Mintu poměrně snadná. Postupujte přesně podle pokynů pro architekturu, na níž je postaven váš počítač. To, zda máte 32-bitový (i686) nebo 64-bitový systém, zjistíte buď v Nastavení systému > System Info nebo zadáním tohoto příkazu v terminálu:

Příkaz terminálu:
uname -m

 

Upozorňuji vás, že aktualizace jádra v Linux Mintu je sice poměrně jednoduchá záležitost, vyžaduje však pokročilé znalosti systému a provádíte jí vždy na vlastní nebezpečí!

 

 

Instalace jádra 4.0 v 32-bitové verzi Linux Mintu

Opět použijeme příkaz „vše v jednom“. Vše budeme provádět pomocí terminálu, tak si jej otevřete a zadejte:

Příkazy terminálu:
cd /tmp && wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.0-vivid/linux-headers-4.0.0-040000_4.0.0-040000.201504121935_all.deb http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.0-vivid/linux-headers-4.0.0-040000-generic_4.0.0-040000.201504121935_i386.deb http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.0-vivid/linux-image-4.0.0-040000-generic_4.0.0-040000.201504121935_i386.deb && sudo dpkg -i *.deb

 

Instalace jádra 4.0 v 64-bitové verzi Linux Mintu

V terminálu zadejte:

Příkazy terminálu:
cd /tmp && wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.0-vivid/linux-headers-4.0.0-040000_4.0.0-040000.201504121935_all.deb http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.0-vivid/linux-headers-4.0.0-040000-generic_4.0.0-040000.201504121935_amd64.deb http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.0-vivid/linux-image-4.0.0-040000-generic_4.0.0-040000.201504121935_amd64.deb && sudo dpkg -i *.deb

 

Následně aktualizujte zavaděč Grub a restartujte počítač:

Příkazy terminálu:
sudo update-grub
sudo reboot

Po restartu počítače si v Grubu vyberete spuštění Mintu s jádrem 4.0 a mělo by vše běhat (bez záruky). Pokud tomu tak není, vyberte si v Grubu spuštění Mintu se starším kernelem a ten nový odstraňte tímto příkazem v terminálu:

Příkaz terminálu:
sudo apt-get purge linux.image-4.0.0-*

 

Sám jsem otestoval tento nejnovější stabilní kernel na Linux Mintu 17.1 Rebecca s pracovním prostředím Cinnamon a na LMDE 2 Betsy s prostředím Mate, kde s mou hardwarovou konfigurací běhá naprosto bez problémů. V komentářích rád uvítám i vaše poznatky z instalace nového stabilního jádra do jiných verzí Linux Mintu.

Přeji hodně úspěchů při instalaci i práci s nejnovějším stabilním kernelem 4.0.

 

Štítky , , , , , , , .Záložka pro permanentní odkaz.

48 reakcí na Jak nainstalovat kernel 4.0 v Linux Mintu

  1. WilomanCZ říká:

    Mám odzkoušení na LMDE 2 32bit Mate u velmi nevýkonného PC a jede nejlepé ze všech kernelů co jsem zatím měl od 3.16 až po 3.19 (ten byl nejhorší občas vše černalo nebo se ztrácely obrázky atd).

  2. radekhodal říká:

    nvidia gtx 295 nejede s ovladacem nvidia 340….

    Linux Mintu 17.1 Rebecca s pracovním prostředím Cinnamon

  3. Rostislav Bačovský říká:

    Naprostý souhlas s WilomanCZ, absolutně excelentní záležitost. 3.19.x byl masakr. Pro mne poslední funkční byl kernel 3.16.8, pak až tento.

  4. Rostislav Bačovský říká:

    3.18.6 samozřejmě, 🙂

  5. radekhodal říká:

    prosim sapatouch jak naistalovat ovladac. stahl jsem soubor NVIDIA-Linux-x86_64-346.59.run

  6. radekhodal říká:

    su v pasti….kdyz dam kernel 4.0 s ovladacem nvidia 340 nic se nerozjede, jakoby modra smrt a napise mi to „spusteni serveru X (vaseho grafickeho adapteru) selhalo. ovlada nvidia 346 neumim naistalovat a kernel 3.9 kdyz dam zpet a ze svobodneho grafickeho adapteru noveau (kdy pc jede neco jako v nouzovem rezimu) dam zpet ovlada nvidia 340 nic se nedeje. chjo. pomozte. dekuju

    • Kebab říká:

      Jedu na Xfce ale to by nemělo být důležité, také mně to odmítlo s novým kernelem jak píšeš ovladač 340, jsem v linuxu pořád někde za startovní čárou ale nevím v čem máš problém: normálka jsem vyvolal Driver Manager, chvíli počkal a zobrazila se mně nabídka ovladačů a kde byla nabídnuta i 346, označil jsem a musel nějakou dobu čekat … potom konec a to bylo vše, natáhl jsem nový systém s novým kernelem … a co nechodilo tedy grafika tak už bez problému chodí

      • radekhodal říká:

        takze tam potrebuju dostat driver 346….jak na to?

        • Kebab říká:

          já asi před 3 až 4 měsíci měnil grafickou kartu ATI za novou nVidia, před tím mě ovladače nezajímaly teď musely, zjistil jsem jaký ovladač mám mít a tehdy to byla 340 a postupoval jsem nějak dle
          http://www.linux-mint-czech.cz/jak-nainstalovat-nejnovejsi-ovladace-nvidia-v-linux-mintu-17-qiana/
          no a teď a opět opakuji aniž bych cokoli dělal jsem ten nový ovladač 346 už měl v nabídce v Driver Manager … a chvíli to trvalo tudíž předpokládám že po označení se „cosi“ dohrávalo … tudíž abych řešil to co ty řešíš tj. stahoval sám a potom řešil jak dál … tak to jsem vůbec nepotřeboval a už bych se opakoval, pro mne to byla záležitost kolik … asi 10 minut? Toto teď píšu už pod novým kernelem a s novým ovladačem.

  7. Luky říká:

    Tento návod, teda toto jadro z Ubuntu ppa môžem použiť aj v LMDE2 ?

  8. Petr Nowak říká:

    Zkoušel jsem jádra verze 3.16 – 3.15 – 3.16 – 3.17 a až teď verzi 4.0. Systém je rychlejší a zatím nejeví žádnou známku, že by bylo něco špatně. U verzí jader: 3.18 – 3.19 se stávalo, že to skončilo novou instalací s původním instalačním jádrem 3.13 (viz DVD se systémem).

  9. Pačula říká:

    Tak nainstalováno a vše O.K 🙂

  10. Pajus říká:

    Tak mě u tohoto jádra nejede internet ale to dam do pořádku. Mam ovladače Nvidia 349.12 a žadny problém.

  11. radekhodal říká:

    nic….na prd…porad havarie nic nejde…..

    • Kebab říká:

      No podle toho co jsi dosud napsal tak jsi to nešťastně rozvařil, musíš se dostat do výchozího stavu když ti to fungovalo a pod předchozím kernelem, a co se týče ovladačů nVidia tak postupovat dle zveřejněného návodu, nabídku dostupných ovladačů budeš mít přes Driver Manager a ty jsi se pokoušel dělat „cosi“ místo něho a po svém

      • radekhodal říká:

        zkusim nahrat minta znovu citou instalaci. potom napisu jak to dopadlo. dekuju za reakce a za pomoc

  12. gabo říká:

    Zdravim,

    po instalaci mi prestatla fungovat wifi
    $ifconfig
    eth0 Link encap:Ethernet HWaddr 3c:97:0e:ef:7b:d2
    inet addr:192.168.200.28 Bcast:192.168.200.255 Mask:255.255.255.0
    inet6 addr: fe80::3e97:eff:feef:7bd2/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:2337 errors:0 dropped:51 overruns:0 frame:0
    TX packets:2098 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:1400240 (1.4 MB) TX bytes:305332 (305.3 KB)

    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    inet6 addr: ::1/128 Scope:Host
    UP LOOPBACK RUNNING MTU:65536 Metric:1
    RX packets:481 errors:0 dropped:0 overruns:0 frame:0
    TX packets:481 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:66652 (66.6 KB) TX bytes:66652 (66.6 KB)


    $lspci -nn | grep -i network
    02:00.0 Network controller [0280]: Broadcom Corporation BCM43142 802.11b/g/n [14e4:4365] (rev 01)

    Dakujem.

  13. Arnošt říká:

    Tak u mně je asi nové jádro nekompatibilní s grafickou kartou. Po instalaci to vypíše chybu, že i915 je nekompatibilní a po restartu bliká obraz, vypíná a zapíná se. Takže jsem musel odinstalovat…
    Ovladač grafiky jsem instaloval podle návodu tady, grafická karta Intel. Dá se nějak odinstalovat? Vrátit se k původnímu ovladači grafické karty?

    • Barthezz říká:

      jo tak to by me taky zajimalo.. mam presne ten stejny problem, mam HD3000 a v tomto kernelu me blika obraz, v 3.19.3 vse v poradku

  14. Floyd říká:

    Kernel 4.0 nainstalován bez problémů.

  15. Boleslav Křišťál říká:

    Hlásím, že Kernel 4.0 nainstalován bez problémů 🙂 Provedl jsem všechny kroky včetně aktualizace zavaděče Grub a restartu počítače. Ovšem mate mne jedna věc – ve Správci aktualizací > Zobrazit > Linuxová jádra … se mi zobrazují všechna předchozí jádra 3.13.0, 3.16.0 a 3.19.3, ale vůbec se mi nezobrazuje jádro 4.0 (?) Mám nainstalován GNU Linux Mint 17.1 Rebecca Xfce. Všechna ostatní předchozí se mi zobrazovala. Kde je problém?! Jak mám toho docílit? Předpokládám, že nejsem jediný, takže odpověď spolu s radou „co a jak“ se určitě bude hodit více lidem. Děkuji předem za odpověď 🙂

    • Ukomir říká:

      V tom správcovi sa ukazujú dostupné jadrá.Ak chcete zistit svoje aktuálne zadajte do terminálu príkaz „uname -a“
      Alebo Menu-Systemove nastroje-Monitor systemu/system.
      Odporúčam aj nainštalovat Ubuntu Tweak,na odinštalovanie starých jadier.

      • Kebab říká:

        To co píšeš je sice řešení, tj. jak se ubezpečit že právě mám aktuálně nové jádro 4.0, ale nic to nemění na tom že i já jsem narazil na popisovaný renonc (také mám Xfce) a v přehledu ve Správci aktualizací toto nové jádro chybí … a chybět by nemělo a je to absurdní chyba když před tím jsem tento problém po aktualizaci jádra nezaznamenal.
        Přišel jsem na to tak, že jsem chtěl odstranit jádro předchozí (nechávám si trvale do zálohy jen to původní z Mintu) a najednou to nové začínající 4 tam nebylo. Předpokládám že to opraví a dá se bez toho žít.

        • ukomir říká:

          To som si doteraz nevšimol,že aj cez Správcu aktualizácii sa dajú od/inštalovat kernely.Mne sa tam tiež neukazuje,ale bude to najskôr tým,že sa aktuálne používa a tudíž sa nedá nič s ním robit aktuálne(od/instalovat).Ak sa prehodíte do iného kernelu,predpokladám,že potom tam ukáže aj to posledné 4.0

          • Kebab říká:

            Smiř se s tím, že Linux tedy některé komponenty včetně nadstavby má také chyby. A tato je pro mne, cha, chááá a přišlého z Woken, opravdu chyba trapná ale jak už jsem napsal, tak žít se s tím dá.
            Toto píšu totiž pod nataženým kernelem zpět k 3.19.3 a ve Správci aktualizací v přehledu není po kernelu 4.0 památky, ač ho tam mám jako standard, a správně 3.19.3 v přehledu také je (píšeš tedy zde zjevné nepravdy) a navíc je označený ve sloupečku že je nahraný, což je také pravda a mezi jinými v přehledu je řádek s ním zobrazen tučně.
            Měli by to někdy opravit.

            • Boleslav Křišťál říká:

              Nakonec jsem odinstaloval jádro 4.0.0 a ta ostatní, která byla přidaná navíc mnou mimo oficiální aktualizace a menu v systému, a nezobrazovalo se u nich „instalovat“, takže mám nakonec viditelná pouze oficiální jádra 3.13.0-* a 3.16.0-* skrze běžné aktualizace systému. Nainstaloval jsem si nazpět 3.13.0-37 jako ‚doporučené‘, i když několikrát opravené & vylepšené. Při odstraňování jednotlivých neoficiálních jader jsem musel PC několikrát aktualizovat, protože se mi při „uname -a“ neustále zobrazovalo jako hlavní jádro 4.0.0. a když jsem zadal příkaz k jeho odstranění, tak se mi zobrazila hláška, že neexistuje. Teď už se mi zobrazuje, jak skrze terminál, tak i skrze aktualizaci systému, to moje aktuální, oficiální a funkční jádro. Nejsem sice ajťák 🙂 ale mám rád ve věcech pořádek a nesnáším zbytečný chaos 🙁 a chyby z pohodlnosti; některé jsou i úmyslné! Buďme opatrní. Nejvíce mne „dojala“ >:-( situace kolem OpenSSL a jeho „krvácejícího srdce“. Soukromí má velkou hodnotu. Važme si ho!

  16. radekhodal říká:

    reinstal…….

  17. Ján Batiz říká:

    Linux Mint 17.1 MATE 64bit
    AMD A6-7400K Radeon R5
    Pamäť 3.2GB
    SSD 64GB
    Kernel 3.19.2 ide v pohode s ovladačmi
    xserver-xorg-video-ati 1:7.3.0-1ubuntu3.1(doporučené)
    aj s proprietárnym ovladačom fglrx 2:13.350.1-0ubuntu2
    Kernel 3.19.3 ide tiež
    Kernel 4.0 nefunguje ani s jednym ovladačom po reštarte hlási
    NIE JE MOŽNÉ SPUSTIŤ XSERVER ASI NIEJE SPRÁVNE NASTAVENÝ (verzia x.org x server 1.15.1)
    v aktualizáciách mám pripravený nový xorg-server 2:1.15.-0ubuntu2.7 je ale v úrovni 4 tak neviem či to môžem aktualizovať

  18. Andreas říká:

    Linux mint 17.1 x64 Mate
    intel Pentium dual core 2.00 GHz, RAM 2GB, Nvidia 9500GT

    Fungoval jsem původně na základním kernelu, který je po čisté instalaci LM. Zprovoznil jsem GK Nvidia pod ovladačem 340.76.

    Při aktualizaci kernelu 4.0 se už nepodařilo GK rozjet. (je možné, že je to stářím hardware) Byl jsem nucen přeinstalovat PC, takže zase funguji na základním kernelu a vše šlape. Nechám být, jak to je 🙂

    • Kebab říká:

      A proč jsi dělal přeinstalaci? Já jsem se vrátil k předchozímu jádru při natahování systému (GRUB?) a ten s ovladačem 340 fungoval jako před tím, přes Driver Manager jsem označil a „natáhl“ nový další a zde už doporučený ovladač, dal jsem restart a potom jsem při natahování systému zvolil ten nový kernel 4.0 a šlape to zatím jako hodinky.
      Průšvih by pro mne byl, kdyby nový ovladač nefungoval jak pod novým jádrem tak zpětně ani pod tím předchozím.

      • Andreas říká:

        No a to byl právě můj případ. Přesně to jsem udělal, vrátil jsem se ke starému jádru přes Grub a ovladač grafiky Nvidia jsem už nerozjel ani pod tímto jádrem.
        Zapomněl jsem toto info do předchozího komentáře napsat..

  19. Sante říká:

    Měl jsem stejný problém s tímto novým jádrem. Postupval jsem jak píše Kebab a do systému se přihlásil s předchozím jádrem. Ve správci ovladačů jsem pak nastavil ovladač xserver-xorg. Pak znovu restart a pod novým jádrem už není žádný problém. Není tedy potřeba dělat reinstal systému, postupujte jak píše Kebab.

  20. tomkom18 říká:

    Takže po dlhom, dlhom čase som sa rozhodol pre update kernelu a neľutujem. Systém je rýchlejší snáď 30%. Len som musel ručne nainštalovať wifinu (Broadcom) podľa tohto návodu http://askubuntu.com/questions/55868/installing-broadcom-wireless-drivers. Inak Nvidia driver 340 som inštaloval ešte pred updatom kernelu. Moc som s ním neni ale spokojný.

  21. radekhodal říká:

    ty vole….10x reinstal komplet mint 17.1…… jednou za celou dobu se mi to na chvilku rozjelo s ovladacem grafic nvidia 331…..340 or 346 vubec konec total eror…..zduraznuji …….vse na CISTA NOVA TOTAL CISTA instalace linujx mint 17.1…………

    HW: i7 875k, gainward nvidia 295 gtx, 16 gb ram

    co vic chce linux mint aby fakcil

    furt modra obrazovka ze X SERVER selhal

  22. radekhodal říká:

    sakra co to je za system ten linux mint….veril jsem mu……furt jen 4.0 reinsdtal asi 12x furt je nvidia 331 furt modera smrt SERVER X total eror sakra co to je kuzrva

    • Kebab říká:

      Ber to ode mne jako možnou jen laickou připomínku protože sám jsem v Mintu (Linuxu) někde teprve za startovní čarou, takže si to sám prosím tě ověř protože já jsem mohl mít vlčí mlhu:
      pokud postupuješ dle návodů, tak na webu nVidia jsi měl sobě nejdříve(!) ověřit(!) jaký ovladač je k tvé kartě,
      mně když jsem zadal pro Linux 64 bit a tvoji grafickou kartu tak poslední driver je 340.76,
      kontrolně pro moji kartu GT730 mně už nVidia nabídne ten 346.59,
      ***************
      tudíž ty se a dle mne dobýváš do zatím zavřených dveří, to že 340 nesedí pro kernel 4.0 tu je vícekrát uvedeno a abys tam dal zde uváděný 346.59 tak zase nVidia ho nepáruje k tvé kartě,
      máš asi zatím proto smůlu, také nahoře Satapouch ti napsal slovo „zkus“ a nikoli tvrzení že to s tímto ovladačem půjde,
      zkusil jsi to a nejde a kdybys s prominutím byl pozornější a četl návod a ověřil si ovladače pro tvoji kartu u nVidia, tak jsi sobě mohl ušetřit 11x reinstal z těch uváděných 12 … a nic ve zlém já jsem si podobných zoufalostí také něco prožil jindy a jinde

      • radekhodal říká:

        kluci po 13 to musi uz slapat.ted uz vim ze ovlada a karta musi lícovat, svobodny ovladac by mel jet vzdy.chvili mi to jelo s 331. jste hodni.dekuju.posledne jsem uz byl zoufaly, proto ty slova.dekuji.budu skouset dal. Radek

        • Kebab říká:

          Já předchozí kartu měl od konkurenta ATI HD 2600 Pro. Po asi 20 letech pod různýma Widlema jsem zkusil před rokem Linux. No a tady jsem zjistil, že pokud bych chtěl něco jiného než Linuxem nabídnutý svobodný ovladač tak mám smůlu, karta už ztratila a i když byla slušně schopná i starších her podporu. Tudíž konec s dalším rozvojem.
          Ta tvá karta je a jak jsem zvědavě koukal něco podobného, před těmi lety výkonná karta s příznivými recenzemi ale dnes je to už minulost i když pořád také nevím, proč ji (zatím?) jakoby od nového kernelu přes nesvobodný ovladač odřízli.
          To že by svobodný ovladač měl jít vždy si také nejsem jistý, myslím hned od počátku s novou řadou kernelu, v situaci kdy třeba Mint má oficiální jádro pořád 3.x a ty jsi, u kernelu 4.0, na úrovni experimentu a výsledek (zatím) může být ten že se to nesrovná, podobně tak a jako příklad že kernel 4.0 není vidět ve Správci aktualizací: to budou muset teprve doladit a formálně si to nelze vynucovat, protože oficiálně máme mít kernel ten starší 3.x a tam jak předpokládám ovladač šlape. Viz příspěvek nahoře kde autor nakonec už experimentovat nechtěl a kernel 4.0 odinstaloval.

  23. radekhodal říká:

    takze kluci po tydnu trapeni….kernel 4.0 mozna sice fajn….ALE!!!!!!!!!!!!!

    mojje sestave i7 875k
    NV gtx 295
    8 gb ram
    gigabyte deska 1156 socket (typ? pro mou recenzi nedulezite)

    tim chci rict ze zas az tak stary HW nemam

    po nekolikanasobne preistalaci komplet novych mintu a tydenniho zkouseni……

    kernel 4.0…..grafika nvidia 304….311….340 hazi pri startu neco jako modre smrt s tim ŽE:……“x server“ total havarie

    takže si asi počkám na další kernel, třeba to pojede………
    vše nejlíp a vzdy slape na kernelu 3.13…..na tom zakladu a 3.19.3 poslednim funkcnim.

    verim ze nejsem sam takovy hnup aby mi vse padalo a neslo. upozornuji ze vse pokud jsem se o cokoli pokousel jsem mel sistou instalaci mintu

    pockam na dalsi kernely. Radek Hodal Frydek Mistek fanda do linux od roku 2014

    • theseuszn říká:

      radekhodal:
      A intel-microcode a linux-firmware-nonfre máš zavedený? Přide mi to, že je nemáš zavedený a nebo si něco udělal špatně v postupu. U tý nvidie proč tam cpeš ty verze dokola, když ti blbnou?
      Tohle ti nefunguje:
      sudo add-apt-repository ppa:xorg-edgers/ppa
      sudo apt-get update
      Neznám nikoho s nividiáckýmja kartama, že by mu to nefungovalo.

  24. radekhodal říká:

    a taky sponzor serveru linux mint cz sk……..

  25. radekhodal říká:

    prosim dejte mi vedet az vyjde funkcni kernel 4x……..na mail radekhodal@email.cz

  26. theseuszn říká:

    Kernel absolutní špica. Sedí jak zadek na míse 😀
    LM 17.1 x64 Cinnamon, proc-AMD X4 750K, grafika-GF GT-740-driver-349.16, základka-GA-F2A85XM-HD3. Jak je již uvedeno, celá řada 3.19.x naprd. Všechny starší v pohodě, to samý s ovladači nvidie.

  27. pajik říká:

    nejede WIFI

    rollback

  28. Petr Klásek říká:

    Notebook Dell D410 procesor Intel Pentium M 1,86GHz, Mint 17.1 KDE
    Instalace se povedla, všechno běží.
    Teprve nedávno jsem přešel z Cinnamonu na KDE a byl jsem překvapený, jak svižně to běží na tak staré mašině. Předpokládám, že na tom mají podíl už předchozí verze jádra.
    Díky za podporu.