GhostBSD prvý pohľad a vs Linux mint 19 xfce vs MX 17.1

Ako testovacia platforma mi poslúžil Fujitsu Siemens Esprimo Mobile D9500 v nasledovnej konfigurácií:

CPU: Intel Core 2 Duo T5250
RAM: 3GB DDR2 SODIMM
Disk: 160GB 5400rpm WD Scorpio Blue
Zvuková karta: Intel 82801H onboard
Grafická karta: Intel Mobile GM965 onboard
Displej: 15,4“ 1280×800 @60Hz
Sieť: LAN, WiFi, 3G modem

Pri oboch linuxoch som sa stretol pri jadre 4.15 a vyššom (4.9 to nerobila) s chybou Intel microcode a atomic update na Linux Mint to bohužiaľ nešlo tak ľahko vyriešiť ako na MX 17.1. Nepomohol ani postup na zápis do grub spomínaný v diskusií. pomohlo až zmena kernelu.
Na GhostBSD sa to neprejavilo, taktiež bez jediného problému našiel 3G modem a aj bez ďaľších nastavení ho pripojil k nastaveniam siete.
Pod linuxami, bolo nutné vložiť sim kartu a manuálne vybrať sieť a nesmel byť na karte aktívny PIN.

Takže čo si v podstate o GhostBSD myslieť.
No je to niečo iné ako GNU/Linux, ale nie až o toľko ako rozdiel medzi GNU/Linux a Windows. Možno je to i tým, že je použíte grafické rozhranie xfce ktoré bežne používam. Alternatívou je použiť GhostBSD s MATE.

Po inštalácií bol prevedený update a doištalovanie ovládačov.
K mojej smole sa mi nepodaril dualboot GhostBSD a Linux Mint, Mint odmietal štartovať z grub pokiaľ bol nainštalovaný GhostBSD ako UFS. riešením bolo previezť vždy čistú inštaláciu OS na disk (keďže som použil testovací HDD a nie livedistribúciu nebol s tým problém)

S GhostBSD sme si celkom sadli, a rozhodol som sa, že pôjde na chvíľu na sekundárny disk do desktopu.

Takže ako ho zhodnotiť?
GhostBSD pôsobí príjemným pocitom, aj pri otvorení Firefoxu a obľúbeného Facebooku nedochádza k znateľným spomaleniam, ktoré sa prejavovali pri Firefoxe v kombinácií s otvorením stránky Facebooku bez Adblocku.
Systém pôsobí svižne, obsadenosť RAM neprekračovala 1,2GB aj pri vytváraní katalógu v DarkTable z 16GB fotiek v Nikon RAW formáte.

Prekvapila ma trochu skladba programov ktorá je na 90% podobná akejkoľvek linuxovej distribúcií. Shotwell, Risretto ako prehliadače obrázkov, Evince na dokumenty, LibreOffice, Mplayer a td.


Obr. GhostBSD screenshoty (virtual box + inštalácia).

GhostBSD

Minimálne systémové požiadavky:
64-bit procesor
1 GB RAM
15 GB voľného miesta na disku
Sieťová karta

Doporučené systémové požiadavky:
64-bit procesor
4 GB RAM
30 GB voľného miesta na disku
Sieťová karta
Zvuková karta
3D grafická karta

Informácie o systéme:
Kernel: 11.1-RELEASE-p15 amd64
Desktop: xfce 4.12.4 (gtk 2.24.31)
OS: GhostBSD (build on FreeBSD 11.1)

Obr. Inxi počas inštalácie v octopkg

Zhodnotenie:

Plusy:
podobnosť s GNU/Linux
stabilita
systémové požiadavky
openRC ako init
výber pred inštalovaných programov
jednoduchá inštalácia na prázdny disk

Mínusy:
nutnosť zvyknúť si na iný systém
zložitá inštalácia na ako dualboot

Pre porovnanie som si vzal Linux Mint 19 a MX17.1, ktoré dobre poznám.  A musím uznať, že GhostBSD oproti tomu, ako som asi pred dvomi rokmi skúšal FreeBSD, sa stal príjemnejším pre užívateľov.

Obr. porovnanie inštalácie a času štartu OS

Linux Mint 19 xfce 

Minimálne systémové požiadavky:
64-bit procesor
1 GB RAM
15 GB voľného miesta na disku
Sieťová karta

Doporučené systémové požiadavky:
64-bit procesor
2 GB RAM (vlastná skúsenosť 4GB)
30 GB voľného miesta na disku
Sieťová karta
Zvuková karta
3D grafická karta

Informácie o OS:
Kernel: 4.15.0-20 generic
Desktop: xfce 4.12.3 (gtk 2.24.31)
OS: Linux Mint 19 (build on Ubuntu 18.04 LTS)

Obr. Inxi

MX17.1

Minimálne systémové požiadavky:
i486 Intel alebo AMD procesor
512 MB RAM
5 GB voľného miesta na disku
Zvuková karta

Doporučené systémové požiadavky:
i686 Intel alebo AMD procesor
1 GB RAM
10 GB voľného miesta na disku
3D grafická karta

Informácie o OS:
Kernel: 4.18.0-9.2-liquorix-amd64
Desktop: xfce 4.12.3 (gtk 2.24.31)
OS: MX17.1 (build on Debian 9 Stretch)

Obr. Inxi

Ak mám zhodnotiť subjektívne činnosť na týchto troch OS, na budúce by som si odpustil používanie Linux Mint.

Dôvodov bolo hneď niekoľko a nechcem vyzerať, že sa schválne opieram do Linux Mint.
Pri inštalácií mal inštalátor problém s partíciou GhostBSD, čo však nie je problém Mintu priamo, ale Ubuntu, ktorého inštalátor Linux Mint používa. Overil som si to následne aj použitím Xubuntu 18.04 a LMDE3.
Po inštalácií mal Linux Mint problém s ovládačmi sieťovej karty Marvell 88E8055 PCI-E 1Gb, čím ma bol schopný pripojiť iba s pomocou wifi. Ďalší problém bol s 3G modemom (použitie 3G modemu ale nebolo podstatné) a s atomic drm, čo mal aj MX 17.1 ale ten sa podarilo vyriešiť 1 reštartom.
Vyťažovanie RAM Linux Mint 19 bolo oproti ostatným abnormálne vysoké, len systemd bral 350MB. Pre porovnanie Linux mint 19 mal spustených 181 procesov a brali si 1125,6MB z RAM oproti 184 procesom na Linux MX ktoré zaberali 476,6MB….

A to pri zavretých veľkých aplikáciách, len základ systému, plus na MX 17 bežalo conky.

Pre overenie som skúšal ešte Linux Mint 17.3 xfce, 18,3 xfce a LMDE 3 Cindy (Cinnamon). Pri týchto distribúciach sa daný problém s vyťažovaním RAM neprejavoval.

 

V ďalšej časti sa pozriem čiste už len na GhostBSD, správanie sa pri činnosti, práca s externými zariadeniami a podobne

Štítky , .Záložka pro permanentní odkaz.

13 reakcí na GhostBSD prvý pohľad a vs Linux mint 19 xfce vs MX 17.1

  1. takyradějianonymně říká:

    Ten důvod napsání článku a který cítím já v pozadí asi také dobře znám. Ono ale ve světě operačních systémů a jejich klonů to pořád funguje podobně stejně a svým způsobem cyklicky: každý chvilku tahá pilku no a nové věci se do světa k uživatelům pouští neodladěné no a to nové se těmto uživatelům jeví navíc i jako často nepříjemně samoúčelné.

    A když už si takový uživatel najde „konečně“ ten svůj a myslí si bezpečný ba jevíce se mu i přátelský přístav, tedy třeba že z Windows přejde na Linux a na právě distribuci Mint a myslí si že to bude už navždy, tak dle zákonitostí a které jsem neuměle popsal v prvním odstavci potom přece „musí“ být z tohoto „omylu“ někdy i někdy brzy vyveden, že? 🙂

    Řešení je vícero a třeba:
    – zůstat na nějaké starší verzi distribuce a ještě s podporou a „kde to ještě funguje“ a v současné přátelsky se jevící a známé komunitě!, no a doufat že se „to“ časem (ano je tu ta cykličnost) zlepší … a ono se to převážně opravdu za čas zlepší, že,
    – hledat alternativy v unixových dalších variantách, já také už po nich zvědavě pokukoval ale … čest odvážným ale mě to nakonec vždy zatím odradilo, myslím abych na ně opravdu přešel,
    – hledat alternativy (mimo také návratu k Windows) stále v Linuxu ale podívat se k také už zavedené konkurenci, myslím opravdové konkurenci co se týče správců distribuce a nikoli jen v klonech téhož a příkladem v klonech a la .buntu a balíčkovacího systému .deb, výsledkem může být zjištění:
    a) že „jinde“ chodí to co dosud nechodilo (přestalo chodit) a že s jen tím .deb. a s PPA svět přece potom nestojí,
    b) že ale je třeba si také toho světa s .deb stále vážit,
    c) že platí současně jak za a) tak za b) a že uživatel by měl být připraven na to, že čas od času prostě přestane být „věrný“ a stane se tím „nevěrným“ ale že zase „někdy“ se zpět k „tomu před tím“ a za čas i vrátí.

    • xxx říká:

      Dôvod članku je, že opäť po čase testujem OS pre „zadávateľa“.
      Popri tom si robím blog, a dúfal som že LM19 bude schopná konkurovať „bsd“ keďže s ním som nemal skúsenosť.

      Zatiaľ z Mintu môžem odporučiť, čo sa stability týka, LMDE3, ale tam je Cinnamon….

      S tým riešením plne súhlasím.
      Ja som neverný LM od 18.00 dôvodom je systemd.

  2. Livan říká:

    Pri testovaní verzie s XFCE v livku som skoro ani nezbadal rozdiel medzi ghostbsd a linuxom. Jediným viditeľným rozdielom bolo, že pri spustení prvej položky livka v grube sa mi notebook sekol. Našťastie druhá položka grubu nabehla bez viditeľných problémov. Vzhľad ovládanie a predinštalované programy podobné bežnému linuxu a keby som si nespustil prehľad cez inxi -F, tak ani nezbadám, že to nie je linux. Jediné, čo ma zarazilo bola prítomnosť programu octopkg alebo podobný názov to malo, ktorý sa veľmi podobal na program octopi známy z arch linuxu. Ten je však naprogramovaný s QT knižnicami a XFCE zasa v GTK. Bližšie som to však neskúmal.

  3. Zann říká:

    Měl bych dotaz, vidím že se za A) fakt vyznáš a za B) jdeš celkem na dřeň v testech. Je to úplně OT ale třeba budeš vědět. Mám tiskárnu se skenerem Samsung M2070W. Pod LM 18.3 fungovalo vše úplně normálně, pod LM 19 funguje buď tis, nebo skenování, oboje nikdy nefunguje korektně. Hledal jsem všude možně a vždycky jsem našel nějaký návod „co ještě doinstalovat“ aby „to“ fungovalo, ale bohužel nikdy to nechodilo jak má. Drivery u samsungů jsou rok staré, tam je to zbytečné, tak hledám pomoc i touto cestou. Pokud máš nějaký nápad, ocenil bych radu, díky 😉

    • xxx říká:

      no to pojde asi len navratom k LM 18.
      na lm19 som nerozbehal sietovu samsung xpress m2875nd
      pod lm 17, 18 za pomoci suldr a nasledne editaciou nastavenia scanneru

      ide pod MX 17.1 krasne dohlada a doinstaluje drivery sam

      • Zann říká:

        Jasně, to jsem si myslel, jen jsem si to chtěl ověřit. Pod LM 18.3 fungují oficiální ovladače pro Ubuntu. S LM 19 halt má uživatel smůlu. Díky.

      • Zann říká:

        Tak zpět. Stačí stáhnout prográmek Vuescan a vše vpohodě funguje i po LM 19, jak tisk tak scanování. To samozřejmě nemění nic na faktu že u samsungů na Linux se**u …

        • xxx říká:

          problem je ze to uz nerobi samsung ale HP.
          Samsung predal diviziu tlaciarni v 2015

          • Zann říká:

            Ale to je jedno kdo to zprasil, koupil to HP, tak se má starat HP, když se to prodává lidem. A teď, když tak o tom uvažuju … jestli on to nebude kopanec někde na straně kernelu Linuxu, když s jinou utilitou to funguje normálně, tak by ten renonc nemusel být nutně na straně Samsungu (HP) coby výrobce driveru. Kdo ví jak to funguje v jiných distrech nezaložených na Ubuntu, resp. Debianu.

            • xxx říká:

              tak HP to len udrzuje. cize cast je u nich.
              co sa tyka inych distier odskusane na mojen multifunkcii:
              Xubuntu HPlip bez problemov,
              Debian 9 /Devuan 2 bez problemov,
              MX17.1 bez problemu
              deepin linux bez problemu
              Antix bez problemu
              Fedora s hplip bez problemu
              LMDE3 s hplip bez problemu,
              LM17 a 18 s suldr bez problemu

              s LM 19 som mal problem, tak skoncil vo virtualboxe…
              Akp rozumne je v lm byt o verziu az dve pozadu (18.3)
              inak na lm19 mi nejde tlacit cez wifi na canone

              • Zann říká:

                Hm, tak v tomhle fakt asi ani Samsung ani HP nejede. Vpodstatě všude to jede bez problémů, akorát na Mintu ne. A s tím že je dobré být na Mintu „pozadu“ máš asi pravdu, ona ta verze 19 stejně nic moc nového nepřinesla.

  4. redhawk75 říká:

    ona ta verze 19 stejně nic moc nového nepřinesla.
    …..
    prave ze priniesla dost zmien.
    najhorsie na tom je, ze oproti Ubuntu v podstate nic nezlespuje.
    kedysi bol mint stabilnejsi, rychlejsi, viac konzervativny. Mal mensiu narocnost na ram a to dokonca v 17.3 aj pri cinnamon.

    tak ale vyvija sa, uvidime ci v 11/12 mesiaci sa to z verziou 19.1 zlepsi

    • Zann říká:

      „najhorsie na tom je, ze oproti Ubuntu v podstate nic nezlespuje.“ … či-li přeloženo do normální řeči, nepřinesla nic. Kdybych chtěl jis novou verzi OS z průseru do průseru, nainstaluju si Windows 10

Napsat komentář

Vaše emailová adresa nebude zveřejněna.